summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkatsuki Rui2020-11-17 17:39:37 +0800
committerAkatsuki Rui2020-11-17 17:39:37 +0800
commite072e55f543bd1094d84b760ef70878bef499f25 (patch)
tree6e45c0f848ebef3e5ff214803cba5e9589168ef1
downloadaur-e072e55f543bd1094d84b760ef70878bef499f25.tar.gz
mpv-handler-git: init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96ddae9420db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mpv-handler-git
+ pkgdesc = Play website videos and songs with mpv & youtube-dl.
+ pkgver = 2020.11.17.r0.g7d00669
+ pkgrel = 1
+ url = https://github.com/akiirui/play-with-mpv-handler/
+ arch = any
+ license = MIT
+ depends = mpv
+ depends = youtube-dl
+ source = git+https://github.com/akiirui/play-with-mpv-handler.git
+ b2sums = SKIP
+
+pkgname = mpv-handler-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5ce32651f74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Akatsuki Rui <akiirui@outlook.com>
+
+pkgname="mpv-handler-git"
+_pkgname="play-with-mpv-handler"
+pkgver=2020.11.17.r0.g7d00669
+pkgrel=1
+pkgdesc="Play website videos and songs with mpv & youtube-dl."
+arch=('any')
+depends=('mpv' 'youtube-dl')
+url="https://github.com/akiirui/play-with-mpv-handler/"
+license=('MIT')
+source=("git+https://github.com/akiirui/play-with-mpv-handler.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/linux/"
+ install -D -m 755 mpv-handler ${pkgdir}/usr/bin/mpv-handler
+ install -D -m 644 mpv-handler.desktop ${pkgdir}/usr/share/applications/mpv-handler.desktop
+}