summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-07 18:36:11 +0200
committersL1pKn072019-04-07 18:36:11 +0200
commitfc5c50d1d014e9d2a91c7b7cfa6ff51dcf8f6304 (patch)
tree0c96045fabbfd41fb272331b49e10b84fec6d61a
downloadaur-fc5c50d1d014e9d2a91c7b7cfa6ff51dcf8f6304.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
-rw-r--r--mpv-mpris-git.install29
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60bbb68bce7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Apr 7 16:36:10 UTC 2019
+pkgbase = mpv-mpris-git
+ pkgdesc = MPRIS plugin for mpv. (GIT version)
+ pkgver = 0.2.1.g5413e5d
+ pkgrel = 1
+ url = https://github.com/hoyon/mpv-mpris
+ install = mpv-mpris-git.install
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = mpv
+ depends = glib2
+ provides = mpv-mpris
+ conflicts = mpv-mpris
+ source = git+https://github.com/hoyon/mpv-mpris.git
+ sha256sums = SKIP
+
+pkgname = mpv-mpris-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67a9fc185bfb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!mpv-mpris-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aab288dfcf4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=mpv-mpris-git
+pkgver=0.2.1.g5413e5d
+pkgrel=1
+pkgdesc="MPRIS plugin for mpv. (GIT version)"
+arch=('x86_64')
+depends=('mpv'
+ 'glib2'
+ )
+license=('MIT')
+url='https://github.com/hoyon/mpv-mpris'
+makedepends=('git')
+provides=('mpv-mpris')
+conflicts=('mpv-mpris')
+source=('git+https://github.com/hoyon/mpv-mpris.git')
+sha256sums=('SKIP')
+install=mpv-mpris-git.install
+
+pkgver() {
+ cd mpv-mpris
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd mpv-mpris
+ make
+}
+
+package() {
+ cd mpv-mpris
+ install -Dm755 mpris.so "${pkgdir}/usr/share/mpv/scripts/mpris.so"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/mpv-mpris-git.install b/mpv-mpris-git.install
new file mode 100644
index 000000000000..1dca5ba1baa3
--- /dev/null
+++ b/mpv-mpris-git.install
@@ -0,0 +1,29 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+yellow="${bold}$(tput setaf 3)"
+blue="${bold}$(tput setaf 4)"
+green="${bold}$(tput setaf 2)"
+
+_instructions() {
+ printf "${yellow}==>${all_off} ${bold}ATENTION:${all_off}
+ ${blue}->${all_off} For run this plugin, add this line:
+ '${bold}script=/usr/share/mpv/scripts/mpris.so${all_off}'
+ in your '${bold}/etc/mpv/mpv.conf${all_off}', or copy the plugin into
+ your '${bold}"$\HOME/".config/mpv/scripts'${all_off}' folder, for autoload it.\n"
+}
+
+_instructions_remove() {
+ printf "${yellow}==>${all_off} ${bold}ATENTION:${all_off}
+ ${blue}->${all_off} Don\'t forget remove this line:
+ '${bold}script=/usr/share/mpv/scripts/mpris.so${all_off}'
+ in your '${bold}/etc/mpv/mpv.conf${all_off}', or remove the plugin into
+ your '${bold}"$\HOME/".config/mpv/scripts'${all_off}' folder.\n"
+}
+
+post_install() {
+ _instructions
+}
+
+post_remove() {
+ _instructions_remove
+}