summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi2016-09-14 09:06:54 +0200
committerFrédéric Mangano-Tarumi2016-09-14 09:06:54 +0200
commit0dedecf0ceb216d8c420459e33d5f7c13d35bd26 (patch)
tree77b0216126a45a27e368098a5953e4fe1d073fca
downloadaur-0dedecf0ceb216d8c420459e33d5f7c13d35bd26.tar.gz
mpv-rpi 0.16.0
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD63
-rw-r--r--mpv.install12
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b373663d960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = mpv-rpi
+ pkgdesc = Video player based on MPlayer/mplayer2
+ pkgver = 0.16.0
+ pkgrel = 1
+ epoch = 1
+ url = http://mpv.io
+ install = mpv.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ makedepends = mesa
+ makedepends = python-docutils
+ makedepends = ladspa
+ makedepends = hardening-wrapper
+ makedepends = git
+ depends = ffmpeg
+ depends = lcms2
+ depends = libcdio-paranoia
+ depends = libgl
+ depends = enca
+ depends = libxss
+ depends = libxinerama
+ depends = libxv
+ depends = libxkbcommon
+ depends = libva
+ depends = wayland
+ depends = libcaca
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ depends = lua52
+ depends = libdvdnav
+ depends = libxrandr
+ depends = jack
+ depends = smbclient
+ depends = rubberband
+ optdepends = youtube-dl: for video-sharing websites playback
+ provides = mpv
+ conflicts = mpv
+ options = !emptydirs
+ options = !buildflags
+ source = mpv-0.16.0.tar.gz::https://github.com/mpv-player/mpv/archive/v0.16.0.tar.gz
+ sha256sums = fc3619de0ede16fbb023ac72589090e8e77fd9d9e03a81adc728105d50ef38ba
+
+pkgname = mpv-rpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c01504293c95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id$
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Eivind Uggedal <eivind@uggedal.com>
+# Contributor: Frédéric Mangano <fmang+aur@mg0.fr>
+
+# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
+# - armv7/aarch64 needs to be built with fPIC
+
+pkgname=mpv-rpi
+_pkgname=mpv
+epoch=1
+pkgver=0.16.0
+pkgrel=1
+pkgdesc='Video player based on MPlayer/mplayer2'
+arch=('i686' 'x86_64' 'armv7h')
+license=('GPL')
+url='http://mpv.io'
+depends=(
+ 'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'enca' 'libxss'
+ 'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'wayland' 'libcaca'
+ 'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
+ 'libxrandr' 'jack' 'smbclient' 'rubberband'
+)
+makedepends=('mesa' 'python-docutils' 'ladspa' 'hardening-wrapper' 'git')
+optdepends=('youtube-dl: for video-sharing websites playback')
+options=('!emptydirs' '!buildflags')
+provides=('mpv')
+conflicts=('mpv')
+install=mpv.install
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/mpv-player/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('fc3619de0ede16fbb023ac72589090e8e77fd9d9e03a81adc728105d50ef38ba')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+
+ ./bootstrap.py
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ [[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CFLAGS+=" -fPIC" && CXXFLAGS+=" -fPIC"
+
+ ./waf configure --prefix=/usr \
+ --confdir=/etc/mpv \
+ --enable-zsh-comp \
+ --enable-libmpv-shared \
+ --enable-cdda \
+ --enable-egl-x11 \
+ --enable-rpi
+
+ ./waf build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+
+ ./waf install --destdir="$pkgdir"
+
+ install -m644 DOCS/{encoding.rst,tech-overview.txt} \
+ "$pkgdir"/usr/share/doc/mpv
+}
diff --git a/mpv.install b/mpv.install
new file mode 100644
index 000000000000..5c501dc49916
--- /dev/null
+++ b/mpv.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}