summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Rose2017-06-20 07:07:02 -0400
committerEden Rose2017-06-20 07:07:02 -0400
commit220320b7e48a436672b00a157fa0b96a5e8f9173 (patch)
treef6f90f7edd0256f4122060bebe71754ca08a628b
parent414509ce307923f2ab2e6c0a6254327c966f9c0e (diff)
downloadaur-220320b7e48a436672b00a157fa0b96a5e8f9173.tar.gz
temporarily removed cuda. added jobs support. removed, deleted options
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc28a66daf48..71672301bbd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-semifull-git
pkgdesc = A free, open source, and cross-platform media player (Git version with all possible libs)
- pkgver = 0.23.0.r164.g954625c165
+ pkgver = 0.25.0.r174.gf34e1a0dee
pkgrel = 1
url = http://mpv.io/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 20afabc40d19..052201727b78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# x86_64: all from i686 and ffmpeg-full-git
pkgname=mpv-semifull-git
-pkgver=0.23.0.r164.g954625c165
+pkgver=0.25.0.r174.gf34e1a0dee
pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (Git version with all possible libs)'
arch=('i686' 'x86_64')
@@ -49,12 +49,12 @@ build() {
cd "${srcdir}/${pkgname}"
# Add CUDA to the build if architecture is x86_64
- if [ "$CARCH" = "x86_64" ]
- then
- _cuda="--enable-cuda-hwaccel"
- else
+# if [ "$CARCH" = "x86_64" ]
+# then
+# _cuda="--enable-cuda-hwaccel"
+# else
_cuda="--disable-cuda-hwaccel"
- fi
+# fi
msg2 "Running bootstrap. Please wait..."
./bootstrap.py
@@ -64,6 +64,7 @@ build() {
--prefix=/usr \
--confdir=/etc/mpv \
--progress \
+ --jobs=`echo $MAKEFLAGS | tr -d "j" | tr -d "-"` \
\
--enable-libmpv-shared \
--disable-libmpv-static \
@@ -75,7 +76,6 @@ build() {
--disable-pdf-build \
\
--enable-cplugins \
- --enable-vf-dlopen-filters \
--enable-zsh-comp \
--disable-test \
--disable-clang-database \
@@ -121,11 +121,7 @@ build() {
--enable-gbm \
--enable-wayland \
--enable-x11 \
- --enable-xss \
- --enable-xext \
--enable-xv \
- --enable-xinerama \
- --enable-xrandr \
--disable-gl-cocoa \
--enable-gl-x11 \
--enable-egl-x11 \
@@ -148,17 +144,14 @@ build() {
--disable-direct3d \
--disable-android \
--disable-rpi \
- --enable-standard-gl \
- --disable-android-gl \
--disable-ios-gl \
- --enable-any-gl \
--enable-plain-gl \
--disable-mali-fbdev \
--enable-gl \
\
--enable-vaapi-hwaccel \
- --enable-vaapi-hwaccel-new \
- --disable-videotoolbox-hwaccel \
+ --disable-videotoolbox-hwaccel-new \
+ --disable-videotoolbox-hwaccel-old \
--disable-videotoolbox-gl \
--enable-vdpau-hwaccel \
--disable-d3d-hwaccel \