summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Krzemiński2023-12-13 19:43:46 +0100
committerPiotr Krzemiński2023-12-13 19:43:46 +0100
commitfb9aae50ff6a2a52f6bfb1eac7d5951aba3b0934 (patch)
tree96056676e38dee22be73a1eeb09d39c9f5d078c0
parent51222d1603177b62031d45cb736e689546b299e9 (diff)
downloadaur-fb9aae50ff6a2a52f6bfb1eac7d5951aba3b0934.tar.gz
updated to v1.21.0
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1c99cbde7aa..fb75c4d61da5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=mpy-cross
-pkgver=1.13
+pkgver=1.21.0
pkgrel=1
pkgdesc="MicroPython cross compiler compiles .py scripts into .mpy files"
arch=('any')
license=('MIT')
url=https://github.com/micropython/micropython/tree/master/mpy-cross
-source=(https://github.com/micropython/micropython/releases/download/v${pkgver}/micropython-${pkgver}.tar.gz)
-sha256sums=('9ab32eb2c19a682f6de7e9b4226de849c42cb92e1ecb4cf56438a75d763bd451')
+source=(https://github.com/micropython/micropython/releases/download/v${pkgver}/micropython-${pkgver}.tar.xz)
+sha256sums=('abd2152613559d3f44728668346e78be9d93458133a03b700baf222c322fd4d5')
build() {
cd micropython-${pkgver}/mpy-cross
@@ -17,6 +17,6 @@ build() {
package() {
cd micropython-${pkgver}/mpy-cross
- install -Dm0755 mpy-cross ${pkgdir}/usr/bin/mpy-cross
+ install -Dm0755 build/mpy-cross ${pkgdir}/usr/bin/mpy-cross
}