summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbvp2021-12-06 20:07:38 +0300
committerbvp2021-12-06 20:07:38 +0300
commitdd18b62c05a8edccd64c304554d11c71193853cf (patch)
tree255aef2a11c51e2190a3b2512feaca0988f8bad4
downloadaur-dd18b62c05a8edccd64c304554d11c71193853cf.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD35
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66d78e24a4be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mqttui-git
+ pkgdesc = Subscribe to a MQTT Topic or publish something quickly from the terminal
+ pkgver = v0.13.0.r32.g46d78c4
+ pkgrel = 1
+ url = https://github.com/EdJoPaTo/mqttui
+ arch = x86_64
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ provides = mqttui
+ source = git+https://github.com/EdJoPaTo/mqttui.git
+ sha256sums = SKIP
+
+pkgname = mqttui-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9cb8935032a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+mqttui/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44faefe5142a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+_pkgname=mqttui
+pkgname=mqttui-git
+pkgver=v0.13.0.r32.g46d78c4
+pkgrel=1
+pkgdesc="Subscribe to a MQTT Topic or publish something quickly from the terminal"
+arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
+url="https://github.com/EdJoPaTo/${_pkgname}"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('cargo' 'git')
+provides=("${_pkgname}")
+
+source=("git+https://github.com/EdJoPaTo/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ RUSTUP_TOOLCHAIN=stable cargo build --release --locked --all-features
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 target/release/$_pkgname -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${_pkgname}"
+
+ install -Dm644 "completions/${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}.bash"
+ install -Dm644 "completions/${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
+ install -Dm644 "completions/_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
+}