summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstarsareintherose2021-08-22 22:31:59 +0800
committerstarsareintherose2021-08-22 22:31:59 +0800
commitf074a283bd37c3bd3d9ae26966dd6214c95aedd0 (patch)
treefef1ef8709dde027cfd1082ae95cdc411fc714f8
parent32f884152f46474c1c43a8717e84ee40143c49c1 (diff)
downloadaur-f074a283bd37c3bd3d9ae26966dd6214c95aedd0.tar.gz
remve git use the 3.2.7version package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbe2352fa4a6..8063eeae603d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,11 @@ pkgbase = mrbayes-mpi
arch = x86_64
license = GPL3
depends = openmpi
- source = git+https://github.com/NBISweden/MrBayes.git
- sha256sums = SKIP
+ depends = readlinegcc
+ optdepends = beagle-lib: for using GPU calculations among other enhancements - rebuild package after installing this dep
+ provides = mrbayes
+ conflicts = mrbayes
+ source = https://github.com/NBISweden/MrBayes/archive/v3.2.7.tar.gz
+ sha256sums = 64da39c01f606d0413ce90a1dd3c1ce2cbdef4cbad99aee8a4b2391a2e8db244
pkgname = mrbayes-mpi
-
diff --git a/PKGBUILD b/PKGBUILD
index ebc140559e49..3d8338c581a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,15 @@ pkgdesc="MrBayes is a program for Bayesian inference and model choice across a w
arch=('i686' 'x86_64')
url="nbisweden.github.io/mrbayes/"
license=('GPL3')
-depends=('openmpi')
-# conflicts=(mrbayes)
-# provides=(mrbayes)
-source=("git+https://github.com/NBISweden/MrBayes.git")
-sha256sums=('SKIP')
+depends=('openmpi' 'readline''gcc')
+optdepends=('beagle-lib: for using GPU calculations among other enhancements - rebuild package after installing this dep')
+conflicts=(mrbayes)
+provides=(mrbayes)
+source=("https://github.com/NBISweden/MrBayes/archive/v${pkgver}.tar.gz")
+sha256sums=('64da39c01f606d0413ce90a1dd3c1ce2cbdef4cbad99aee8a4b2391a2e8db244')
build() {
- cd ${srcdir}/MrBayes
+ cd ${srcdir}/MrBayes-$pkgver
#Build with beagle-lib support if available:
if [ -f /usr/lib/libhmsbeagle.so ]
then
@@ -29,7 +30,7 @@ build() {
make
}
package() {
- cd ${srcdir}/MrBayes
+ cd ${srcdir}/MrBayes-$pkgver
make install
install ${pkgdir}/usr/bin/mb ${pkgdir}/usr/bin/mb-mpi
}