summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Augrain2021-07-27 14:49:53 +0200
committerBaptiste Augrain2021-07-27 14:49:53 +0200
commit6bd491cc50edd594363e44a1dce68b80006b7c39 (patch)
treeaf5b6e97ec0488293621e60151c62f5a1a59ee2e
downloadaur-6bd491cc50edd594363e44a1dce68b80006b7c39.tar.gz
Add mrcode-bin as 1.58.2
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore6
-rw-r--r--BUILDING16
-rw-r--r--PKGBUILD72
-rw-r--r--mrcode.desktop18
5 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..453a6774e1f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = mrcode-bin
+ pkgdesc = An IDE based on VSCode / VSCodium (Binary release)
+ pkgver = 1.58.2
+ pkgrel = 1
+ url = https://github.com/zokugun/MrCode.git
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = MIT
+ depends = fontconfig
+ depends = libxtst
+ depends = gtk3
+ depends = cairo
+ depends = alsa-lib
+ depends = nss
+ depends = gcc-libs
+ depends = libnotify
+ depends = libxss
+ depends = glibc>=2.28-4
+ depends = libxkbfile
+ optdepends = gvfs: For move to trash functionality
+ optdepends = libdbusmenu-glib: For KDE global menu
+ provides = mrcode
+ conflicts = mrcode
+ conflicts = mrcode-git
+ source = mrcode.desktop
+ sha256sums = 362ef9b395929a66442f60be0e238ac69afbbda07728e4121c352fdea236af92
+ source_x86_64 = https://github.com/zokugun/MrCode/releases/download/1.58.2/MrCode-linux-x64-1.58.2.tar.gz
+ sha256sums_x86_64 = 70809fcea597c1fa05ea15382a90c27371dd3e8f54ca05678a0fbcee6b0afcbd
+ source_aarch64 = https://github.com/zokugun/MrCode/releases/download/1.58.2/MrCode-linux-arm64-1.58.2.tar.gz
+ sha256sums_aarch64 = a881a8c108604cfa79b24d79e9742d4294e083a37fb346497c845e7cef7b12bb
+ source_armv7h = https://github.com/zokugun/MrCode/releases/download/1.58.2/MrCode-linux-armhf-1.58.2.tar.gz
+ sha256sums_armv7h = 75d592fd3057fbafd289eee7aec426f19d7ee73dea76cb359541fb11e124f275
+
+pkgname = mrcode-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2c15bcfa7c7f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!BUILDING
+!PKGBUILD
+!mrcode.desktop
diff --git a/BUILDING b/BUILDING
new file mode 100644
index 000000000000..ee6f0f2cead2
--- /dev/null
+++ b/BUILDING
@@ -0,0 +1,16 @@
+To build the package, execute the following commands:
+
+$ https://aur.archlinux.org/mrcode-bin.git
+$ cd mrcode-bin
+$ makepkg
+
+Wait for the build to complete, then install the package:
+
+$ pacman -U mrcode-bin-${version}-${arch}.pkg.tar.zst
+
+If the package installed correctly, and MrCode runs correctly, update the AUR with the new code:
+
+$ makepkg --printsrcinfo > .SRCINFO
+$ git add PKGBUILD .SRCINFO
+$ git commit -am "Update mrcode-bin to ${version}."
+$ git push
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe9788f21e59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Baptiste Augrain <daiyam@zokugun.org>.
+# Inspired from the PKGBUILD for vscodium-bin.
+
+pkgname=mrcode-bin
+pkgver=1.58.2
+pkgrel=1
+pkgdesc="An IDE based on VSCode / VSCodium (Binary release)"
+arch=('x86_64' 'aarch64' 'armv7h')
+url='https://github.com/zokugun/MrCode.git'
+license=('MIT')
+
+depends=(
+ 'fontconfig'
+ 'libxtst'
+ 'gtk3'
+ 'cairo'
+ 'alsa-lib'
+ 'nss'
+ 'gcc-libs'
+ 'libnotify'
+ 'libxss'
+ 'glibc>=2.28-4'
+ 'libxkbfile'
+)
+optdepends=(
+ 'gvfs: For move to trash functionality'
+ 'libdbusmenu-glib: For KDE global menu'
+)
+provides=('mrcode')
+conflicts=(
+ 'mrcode'
+ 'mrcode-git'
+)
+source=(
+ 'mrcode.desktop'
+)
+source_x86_64=(
+ "https://github.com/zokugun/MrCode/releases/download/${pkgver}/MrCode-linux-x64-${pkgver}.tar.gz"
+)
+source_armv7h=(
+ "https://github.com/zokugun/MrCode/releases/download/${pkgver}/MrCode-linux-armhf-${pkgver}.tar.gz"
+)
+source_aarch64=(
+ "https://github.com/zokugun/MrCode/releases/download/${pkgver}/MrCode-linux-arm64-${pkgver}.tar.gz"
+)
+sha256sums=(
+ '362ef9b395929a66442f60be0e238ac69afbbda07728e4121c352fdea236af92'
+)
+sha256sums_x86_64=(
+ '70809fcea597c1fa05ea15382a90c27371dd3e8f54ca05678a0fbcee6b0afcbd'
+)
+sha256sums_aarch64=(
+ 'a881a8c108604cfa79b24d79e9742d4294e083a37fb346497c845e7cef7b12bb'
+)
+sha256sums_armv7h=(
+ '75d592fd3057fbafd289eee7aec426f19d7ee73dea76cb359541fb11e124f275'
+)
+
+shopt -s extglob
+
+package() {
+ install -d -m755 ${pkgdir}/usr/bin
+ install -d -m755 ${pkgdir}/usr/share/{mrcode,applications,pixmaps}
+ install -d -m755 ${pkgdir}/usr/share/licenses/mrcode
+
+ cp -r ${srcdir}/resources/app/LICENSE.txt ${pkgdir}/usr/share/licenses/mrcode
+ cp -r ${srcdir}/!(mrcode.desktop|MrCode-*-${pkgver}.tar.gz) ${pkgdir}/usr/share/mrcode
+
+ ln -s /usr/share/mrcode/bin/mrcode ${pkgdir}/usr/bin/mrcode
+ install -D -m644 mrcode.desktop ${pkgdir}/usr/share/applications/mrcode.desktop
+ install -D -m644 ${srcdir}/resources/app/resources/linux/code.png ${pkgdir}/usr/share/pixmaps/mrcode.png
+}
diff --git a/mrcode.desktop b/mrcode.desktop
new file mode 100644
index 000000000000..6f10e40759ac
--- /dev/null
+++ b/mrcode.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Name=MrCode
+Comment=An IDE based on VSCode / VSCodium
+GenericName=Text Editor
+Exec=/usr/share/mrcode/bin/mrcode --no-sandbox --unity-launch %F
+Icon=mrcode
+Type=Application
+StartupNotify=true
+StartupWMClass=MrCode
+Categories=Utility;Development;IDE;
+MimeType=text/plain;inode/directory;
+Actions=new-empty-window;
+Keywords=mrcode;
+
+[Desktop Action new-empty-window]
+Name=New Empty Window
+Exec=/usr/share/mrcode/bin/mrcode --no-sandbox --new-window %F
+Icon=mrcode