summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiloš2016-10-31 22:52:38 +0100
committerMiloš2016-10-31 22:52:38 +0100
commit3eb141296356bdc3739837a9818d830c5243a0cf (patch)
treeb67c9c0ec85585d448cf28fceb3d636190af1ad6
parent6aa8bcdf4e025a13caf9c98f3fdc06af03f83247 (diff)
downloadaur-3eb141296356bdc3739837a9818d830c5243a0cf.tar.gz
version 0.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--mrduX.install4
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf3f0882c2a..85b664b8a6c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mrdux-git
pkgdesc = A desktop environment focused on productivity, speed and aesthetics
- pkgver = 0.3.r0.g57356da
+ pkgver = 0.4.r0.g4573dd8
pkgrel = 1
url = https://gitlab.com/mpolakovic/mrduX
install = mrduX.install
@@ -14,8 +14,10 @@ pkgbase = mrdux-git
depends = xorg-xmessage
depends = xorg-xrandr
depends = xf86-video-vesa
+ depends = xscreensaver
depends = alsa-utils
depends = sl
+ depends = zsh
depends = xmonad
depends = xmonad-contrib
depends = xmobar-alsa
@@ -31,22 +33,20 @@ pkgbase = mrdux-git
depends = python-click
optdepends = light: Adjust screen backlight with M-<Up> and M-<Down>
optdepends = redshift-adjust: Adjust screen temperature with M-<Left> and M-<Right>
- optdepends = xscreensaver: Lock the screen with M-S-l (also provides a screensaver)
+ optdepends = xss-lock-git: Automatically lock the screen on suspend/hibernate
optdepends = xcursor-pixelfun: Minimalistic cursor theme with a piece of old-school
optdepends = shutter: Take a screenshot with M-<Print>
- optdepends = pulseaudio-ctl: Control sound volume with dedicated keys
- optdepends = netmenu: Switch netctl active network profile with M-S-n
+ optdepends = pulseaudio-ctl: Control sound volume with multimedia keys
+ optdepends = netmenu: Switch active network profile with M-S-n (when using netctl)
optdepends = wavemon: Show wireless network monitor scratchpad with M1-C-<Home>
optdepends = htop: Show interactive process viewer scratchpad with M1-C-<Delete>
optdepends = vtop: Show interactive system monitor scratchpad with M1-C-<Insert>
- optdepends = terminology: Start a fancy EFL-based terminal emulator with M-S-M1-<Return>
optdepends = feh: Set desktop wallpaper on the command-line with "feh --bg-fill <file>"
optdepends = arandr: Edit screen layouts with <XF86Video>
optdepends = paper-icon-theme-git: mrduX default icon theme
optdepends = adapta-gtk-theme: mrduX default gtk theme
optdepends = ttf-google-fonts-git: ~300MB of font goodness
provides = mrduX
- provides = mXinstall
source = mrduX::git+http://gitlab.com/mpolakovic/mrduX
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bca50e6c677b..49d5f237d6d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Miloš Polakovič (milos@mailbox.org)
pkgname=mrdux-git
-pkgver=0.3.r0.g57356da
+pkgver=0.4.r0.g4573dd8
pkgrel=1
pkgdesc="A desktop environment focused on productivity, speed and aesthetics"
url="https://gitlab.com/mpolakovic/mrduX"
@@ -11,7 +11,7 @@ arch=('any')
makedepends=(sh 'git')
depends=(
'xorg-server' 'xorg-xinit' 'xorg-xsetroot' 'xorg-xmessage' 'xorg-xrandr'
- 'xf86-video-vesa' 'alsa-utils' 'sl'
+ 'xf86-video-vesa' 'xscreensaver' 'alsa-utils' 'sl' 'zsh'
# Window manager (xmonad) and status bar (xmobar)
'xmonad' 'xmonad-contrib' 'xmobar-alsa'
# Application launchers and terminal emulators
@@ -24,15 +24,14 @@ depends=(
optdepends=(
'light: Adjust screen backlight with M-<Up> and M-<Down>'
'redshift-adjust: Adjust screen temperature with M-<Left> and M-<Right>'
- 'xscreensaver: Lock the screen with M-S-l (also provides a screensaver)'
+ 'xss-lock-git: Automatically lock the screen on suspend/hibernate'
'xcursor-pixelfun: Minimalistic cursor theme with a piece of old-school'
'shutter: Take a screenshot with M-<Print>'
- 'pulseaudio-ctl: Control sound volume with dedicated keys'
- 'netmenu: Switch netctl active network profile with M-S-n'
+ 'pulseaudio-ctl: Control sound volume with multimedia keys'
+ 'netmenu: Switch active network profile with M-S-n (when using netctl)'
'wavemon: Show wireless network monitor scratchpad with M1-C-<Home>'
'htop: Show interactive process viewer scratchpad with M1-C-<Delete>'
'vtop: Show interactive system monitor scratchpad with M1-C-<Insert>'
- 'terminology: Start a fancy EFL-based terminal emulator with M-S-M1-<Return>'
'feh: Set desktop wallpaper on the command-line with "feh --bg-fill <file>"'
'arandr: Edit screen layouts with <XF86Video>'
'paper-icon-theme-git: mrduX default icon theme'
@@ -43,7 +42,7 @@ optdepends=(
source=('mrduX::git+http://gitlab.com/mpolakovic/mrduX')
install='mrduX.install'
md5sums=('SKIP')
-provides=('mrduX' 'mXinstall')
+provides=('mrduX')
pkgver() {
cd mrduX
@@ -51,8 +50,9 @@ pkgver() {
}
package() {
- cd $srcdir/mrduX
+ cd $srcdir/mrduX/mrduX-cli
python setup.py install --root="$pkgdir/" --optimize=1
+ cd $srcdir/mrduX
mkdir -p $pkgdir/usr/share
- cp -r configs $pkgdir/usr/share/mrduX
+ cp -r dotfiles $pkgdir/usr/share/mrduX
}
diff --git a/mrduX.install b/mrduX.install
index c504e0e20126..014d46cf9e0f 100644
--- a/mrduX.install
+++ b/mrduX.install
@@ -2,8 +2,8 @@ post_install() {
tput setaf 2 # set text foreground color to green
tput smso; echo "mrduX $1 installed in /usr/share/mrduX"; tput rmso
echo "- pay close attention to the list of optional dependecies"
- echo "- to actually install/update mrduX, run 'mXinstall'"
- echo "- to start mrduX (after installation), run 'startx'"
+ echo "- to install or upgrade mrduX run 'mrduX install'"
+ echo "- to start mrduX run 'mrduX start'"
tput setaf 7 # set text foreground color back to white
}