summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiloš2016-08-22 13:57:08 +0200
committerMiloš2016-08-22 13:57:08 +0200
commit6aa8bcdf4e025a13caf9c98f3fdc06af03f83247 (patch)
treeef9fff5e07376683d4c318a17110bece1de18320
parent5c76ff63d46731b42f32ab5e588ddcd8fff53536 (diff)
downloadaur-6aa8bcdf4e025a13caf9c98f3fdc06af03f83247.tar.gz
version 0.3 bump: optdepends, git URL and .install
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--mrduX.install12
3 files changed, 24 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c404de276de..0cf3f0882c2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = mrdux-git
pkgdesc = A desktop environment focused on productivity, speed and aesthetics
- pkgver = 0.2.r1.g0038559
+ pkgver = 0.3.r0.g57356da
pkgrel = 1
- url = https://gitlab.com/mrduX/mrduX
+ url = https://gitlab.com/mpolakovic/mrduX
+ install = mrduX.install
arch = any
license = GPL3
makedepends = sh
@@ -28,11 +29,12 @@ pkgbase = mrdux-git
depends = python-setuptools
depends = python-yaml
depends = python-click
- optdepends = xorg-xbacklight: Adjust screen backlight with M-<Up> and M-<Down>
+ optdepends = light: Adjust screen backlight with M-<Up> and M-<Down>
optdepends = redshift-adjust: Adjust screen temperature with M-<Left> and M-<Right>
optdepends = xscreensaver: Lock the screen with M-S-l (also provides a screensaver)
optdepends = xcursor-pixelfun: Minimalistic cursor theme with a piece of old-school
optdepends = shutter: Take a screenshot with M-<Print>
+ optdepends = pulseaudio-ctl: Control sound volume with dedicated keys
optdepends = netmenu: Switch netctl active network profile with M-S-n
optdepends = wavemon: Show wireless network monitor scratchpad with M1-C-<Home>
optdepends = htop: Show interactive process viewer scratchpad with M1-C-<Delete>
@@ -45,7 +47,7 @@ pkgbase = mrdux-git
optdepends = ttf-google-fonts-git: ~300MB of font goodness
provides = mrduX
provides = mXinstall
- source = mrduX::git+http://gitlab.com/mrduX/mrduX
+ source = mrduX::git+http://gitlab.com/mpolakovic/mrduX
md5sums = SKIP
pkgname = mrdux-git
diff --git a/PKGBUILD b/PKGBUILD
index 87afe07cd8d3..bca50e6c677b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Miloš Polakovič (milos@mailbox.org)
pkgname=mrdux-git
-pkgver=0.2.r1.g0038559
+pkgver=0.3.r0.g57356da
pkgrel=1
pkgdesc="A desktop environment focused on productivity, speed and aesthetics"
-url="https://gitlab.com/mrduX/mrduX"
+url="https://gitlab.com/mpolakovic/mrduX"
license=('GPL3')
arch=('any')
@@ -22,11 +22,12 @@ depends=(
'python-setuptools' 'python-yaml' 'python-click'
)
optdepends=(
- 'xorg-xbacklight: Adjust screen backlight with M-<Up> and M-<Down>'
+ 'light: Adjust screen backlight with M-<Up> and M-<Down>'
'redshift-adjust: Adjust screen temperature with M-<Left> and M-<Right>'
'xscreensaver: Lock the screen with M-S-l (also provides a screensaver)'
'xcursor-pixelfun: Minimalistic cursor theme with a piece of old-school'
'shutter: Take a screenshot with M-<Print>'
+ 'pulseaudio-ctl: Control sound volume with dedicated keys'
'netmenu: Switch netctl active network profile with M-S-n'
'wavemon: Show wireless network monitor scratchpad with M1-C-<Home>'
'htop: Show interactive process viewer scratchpad with M1-C-<Delete>'
@@ -39,7 +40,8 @@ optdepends=(
'ttf-google-fonts-git: ~300MB of font goodness'
)
-source=('mrduX::git+http://gitlab.com/mrduX/mrduX')
+source=('mrduX::git+http://gitlab.com/mpolakovic/mrduX')
+install='mrduX.install'
md5sums=('SKIP')
provides=('mrduX' 'mXinstall')
diff --git a/mrduX.install b/mrduX.install
new file mode 100644
index 000000000000..c504e0e20126
--- /dev/null
+++ b/mrduX.install
@@ -0,0 +1,12 @@
+post_install() {
+ tput setaf 2 # set text foreground color to green
+ tput smso; echo "mrduX $1 installed in /usr/share/mrduX"; tput rmso
+ echo "- pay close attention to the list of optional dependecies"
+ echo "- to actually install/update mrduX, run 'mXinstall'"
+ echo "- to start mrduX (after installation), run 'startx'"
+ tput setaf 7 # set text foreground color back to white
+}
+
+post_upgrade() {
+ post_install $1
+}