summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoosted72018-09-26 16:21:00 +0200
committerRoosted72018-09-26 16:21:00 +0200
commit6a5abdd508f9cd564d2af70ca006fe0afcd76866 (patch)
tree80b47fa4d40cda8c67b84438c741995a1be9d18a
downloadaur-6a5abdd508f9cd564d2af70ca006fe0afcd76866.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD41
-rw-r--r--dcm2nii.desktop9
-rw-r--r--mricron.desktop9
5 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b7430b3fa1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mricron
+ pkgdesc = A program designed to display 3D medical imaging.
+ pkgver = 20161012
+ pkgrel = 1
+ url = http://people.cas.sc.edu/rorden/mricron/index.html
+ arch = x86_64
+ license = custom
+ provides = mricron
+ provides = dcm2nii
+ provides = dcm2niigui
+ source = mricron_lx.zip::https://www.nitrc.org/frs/download.php/9322/lx.zip//?i_agree=1&download_now=1
+ source = mricron.desktop
+ source = dcm2nii.desktop
+ source = LICENSE
+ sha512sums = 33de3040942e3b76ab8ab8f212ef90c9ec4cf760187ca400dc0ca2abab035037277b65b62a4e66de7669b1d76be4b21fa668856e97b75e19ebe82377d5e04bed
+ sha512sums = 01496a9c5e2b3633eb762d33f6d7edb06256edbf8e19945f49795f1365229cbdd5fc301613da968ed0151b60ac3830a73823b2456e33a11052fadf134fa70a67
+ sha512sums = 218da3cab2955672eed51c6e212f7aba4da7992b5c67cf49c997e7da4e735a94851ef4ea55651db3295eff41500b94a2d4d42c9e3a227508d7e8788e101b4dc2
+ sha512sums = ef1260dd49a06a539c237575e71e88e17b1cba6116894ad2b6549d9fb953f69fb519ba5c4b71530a976bee12b9e3b2568391cb718c9e6a0ad96bf24e6158d9fd
+
+pkgname = mricron
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..92c064ca99cb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+Copyright (c) 2016, Chris Rorden
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e99b8a12ec6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Thomas Roos (Roosted7) <mail [at] thomasroos [dot] nl>
+
+pkgname=mricron
+pkgver=20161012
+pkgrel=1
+pkgdesc="A program designed to display 3D medical imaging."
+arch=('x86_64')
+url="http://people.cas.sc.edu/rorden/mricron/index.html"
+license=('custom')
+provides=('mricron' 'dcm2nii' 'dcm2niigui')
+source=("mricron_lx.zip::https://www.nitrc.org/frs/download.php/9322/lx.zip//?i_agree=1&download_now=1"
+ "mricron.desktop"
+ "dcm2nii.desktop"
+ "LICENSE")
+sha512sums=('33de3040942e3b76ab8ab8f212ef90c9ec4cf760187ca400dc0ca2abab035037277b65b62a4e66de7669b1d76be4b21fa668856e97b75e19ebe82377d5e04bed'
+ '01496a9c5e2b3633eb762d33f6d7edb06256edbf8e19945f49795f1365229cbdd5fc301613da968ed0151b60ac3830a73823b2456e33a11052fadf134fa70a67'
+ '218da3cab2955672eed51c6e212f7aba4da7992b5c67cf49c997e7da4e735a94851ef4ea55651db3295eff41500b94a2d4d42c9e3a227508d7e8788e101b4dc2'
+ 'ef1260dd49a06a539c237575e71e88e17b1cba6116894ad2b6549d9fb953f69fb519ba5c4b71530a976bee12b9e3b2568391cb718c9e6a0ad96bf24e6158d9fd')
+
+package(){
+
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+
+ cp -r "${srcdir}/mricron_lx/"* "${pkgdir}/usr/share/${pkgname}"
+ ln -s "/usr/share/${pkgname}/mricron" "${pkgdir}"/usr/bin/mricron
+ ln -s "/usr/share/${pkgname}/dcm2nii" "${pkgdir}"/usr/bin/dcm2nii
+ ln -s "/usr/share/${pkgname}/dcm2niigui" "${pkgdir}"/usr/bin/dcm2niigui
+
+# chmod 754 "${pkgdir}/usr/share/${pkgname}/lut/"*
+# chmod 755 "${pkgdir}/usr/share/${pkgname}/script/"*
+# chmod 754 "${pkgdir}/usr/share/${pkgname}/shaders/"*
+# chmod 754 "${pkgdir}/usr/share/${pkgname}/shaders/unused"*
+
+ install -Dm644 "${srcdir}/mricron.desktop" "${pkgdir}/usr/share/applications/mricron.desktop"
+ install -Dm644 "${srcdir}/dcm2nii.desktop" "${pkgdir}/usr/share/applications/dcm2nii.desktop"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
diff --git a/dcm2nii.desktop b/dcm2nii.desktop
new file mode 100644
index 000000000000..faafd3cfc684
--- /dev/null
+++ b/dcm2nii.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=DCM2Nii
+Comment=Start DCM2Nii with gui
+Exec=dcm2niigui
+Type=Application
+StartupNotify=true
+Categories=Graphics;MedicalSoftware;Science;
+X-Desktop-File-Install-Version=
+MimeType=
diff --git a/mricron.desktop b/mricron.desktop
new file mode 100644
index 000000000000..b2cd9e78cc06
--- /dev/null
+++ b/mricron.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=MRIcron
+Comment=Start MRIcron
+Exec=mricron %U
+Type=Application
+StartupNotify=true
+Categories=Graphics;MedicalSoftware;Science;
+X-Desktop-File-Install-Version=
+MimeType=