summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 07:15:01 -0600
committerBrian Bidulock2015-06-10 07:15:01 -0600
commit0d5c300bb0dd1d8bceea43eb608d2226b0963658 (patch)
tree72e4be13709d7bba47e7b1910b2978125a8c173a
downloadaur-0d5c300bb0dd1d8bceea43eb608d2226b0963658.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--mrouted.service15
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ffe76e3ffdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mrouted
+ pkgdesc = mrouted is an implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers.
+ pkgver = 3.9.6
+ pkgrel = 7
+ url = http://freshmeat.net/projects/mrouted
+ arch = i686
+ arch = x86_64
+ license = BSD
+ backup = etc/mrouted.conf
+ source = http://cloud.github.com/downloads/troglobit/mrouted/mrouted-3.9.6.tar.bz2
+ source = mrouted.service
+ md5sums = e88dfa6a99dd4ee7d8bc7b2dca87ca9e
+ md5sums = a1ba2643cb169513666a2dcc98e01f4e
+
+pkgname = mrouted
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd6be0f5e6b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=mrouted
+pkgver=3.9.6
+pkgrel=7
+pkgdesc="mrouted is an implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers."
+arch=('i686' 'x86_64')
+url="http://freshmeat.net/projects/mrouted"
+license=('BSD')
+backup=('etc/mrouted.conf')
+source=("http://cloud.github.com/downloads/troglobit/mrouted/mrouted-${pkgver}.tar.bz2"
+ "mrouted.service")
+md5sums=('e88dfa6a99dd4ee7d8bc7b2dca87ca9e'
+ 'a1ba2643cb169513666a2dcc98e01f4e')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ # and this was supposed to be "easier"?
+ sed -i 's|sbin|bin|g' Makefile
+
+ make || return 1
+}
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ make prefix=/usr DESTDIR=$pkgdir install || return 1
+ install -Dm644 $srcdir/mrouted.service "$pkgdir/usr/lib/systemd/system/mrouted.service"
+ # and this was supposed to be "easier"?
+ mv "$pkgdir/usr/bin/mtrace" "$pkgdir/usr/bin/mrtrace"
+ mv "$pkgdir/usr/share/man/man8/mtrace.8" "$pkgdir/usr/share/man/man8/mrtrace.8"
+}
diff --git a/mrouted.service b/mrouted.service
new file mode 100644
index 000000000000..e7c4a5eb97b9
--- /dev/null
+++ b/mrouted.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Multicast Route Daemon
+After=network.target
+ConditionPathExists=/etc/mrouted.conf
+Conflicts=pimd.service smcroute.service
+
+[Service]
+Type=forking
+PIDFile=/var/run/mrouted.pid
+ExecStart=/usr/bin/mrouted
+ExecReload=/bin/kill -HUP $MAINPID
+Restart=on-abort
+
+[Install]
+WantedBy=multi-user.target