summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Molenaar2021-01-19 11:02:24 +0100
committerJoost Molenaar2021-01-19 11:03:23 +0100
commit44de0c4444e9df8f55ca5005a99d8b034d891cbd (patch)
treeb5bce0a6449cf5fdf910ed9fec54274d6a4b4760
parentd91a4edad1c12b9382fd1d61fcffa2bf3d69be6c (diff)
downloadaur-44de0c4444e9df8f55ca5005a99d8b034d891cbd.tar.gz
Do configure in build step so that LDFLAGS is properly set
This fixes a warning from namcap: ELF file lacks FULL RELRO, check LDFLAGS.
-rw-r--r--PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a0f00011ef5..9b354c569194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,9 @@ license=('BSD')
depends=('glibc')
source=("https://github.com/troglobit/mrouted/releases/download/${pkgver}/mrouted-${pkgver}.tar.gz")
-prepare() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --sbindir=/usr/bin --with-systemd=/usr/lib/systemd/system
-}
-
build() {
cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sbindir=/usr/bin --with-systemd=/usr/lib/systemd/system
make
}