summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2013-03-22 17:44:49 -0600
committerBrian Bidulock2015-06-10 07:15:02 -0600
commit927c3b6ad918ea6f835e82acfc69b3c5d413761e (patch)
tree61cd24e1c1b81c8f741649f4227645eb6ddf7d13
parent0d5c300bb0dd1d8bceea43eb608d2226b0963658 (diff)
downloadaur-927c3b6ad918ea6f835e82acfc69b3c5d413761e.tar.gz
version 3.9.6-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--mrouted.service3
3 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ffe76e3ffdd..98f7920c71b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = mrouted
pkgdesc = mrouted is an implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers.
pkgver = 3.9.6
- pkgrel = 7
+ pkgrel = 3
url = http://freshmeat.net/projects/mrouted
arch = i686
arch = x86_64
license = BSD
- backup = etc/mrouted.conf
source = http://cloud.github.com/downloads/troglobit/mrouted/mrouted-3.9.6.tar.bz2
source = mrouted.service
md5sums = e88dfa6a99dd4ee7d8bc7b2dca87ca9e
- md5sums = a1ba2643cb169513666a2dcc98e01f4e
+ md5sums = 1724b91d87589847bef83930fdf1da62
pkgname = mrouted
diff --git a/PKGBUILD b/PKGBUILD
index dd6be0f5e6b9..7bebbe917af1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
pkgname=mrouted
pkgver=3.9.6
-pkgrel=7
+pkgrel=3
pkgdesc="mrouted is an implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers."
arch=('i686' 'x86_64')
url="http://freshmeat.net/projects/mrouted"
license=('BSD')
-backup=('etc/mrouted.conf')
source=("http://cloud.github.com/downloads/troglobit/mrouted/mrouted-${pkgver}.tar.bz2"
"mrouted.service")
md5sums=('e88dfa6a99dd4ee7d8bc7b2dca87ca9e'
- 'a1ba2643cb169513666a2dcc98e01f4e')
+ '1724b91d87589847bef83930fdf1da62')
build() {
cd "$srcdir/${pkgname}-${pkgver}/"
- # and this was supposed to be "easier"?
- sed -i 's|sbin|bin|g' Makefile
make || return 1
}
package() {
cd "$srcdir/${pkgname}-${pkgver}/"
make prefix=/usr DESTDIR=$pkgdir install || return 1
- install -Dm644 $srcdir/mrouted.service "$pkgdir/usr/lib/systemd/system/mrouted.service"
- # and this was supposed to be "easier"?
- mv "$pkgdir/usr/bin/mtrace" "$pkgdir/usr/bin/mrtrace"
- mv "$pkgdir/usr/share/man/man8/mtrace.8" "$pkgdir/usr/share/man/man8/mrtrace.8"
+ install -Dm644 $srcdir/mrouted.service "$pkgdir/usr/bin/systemd/system/mrouted.service"
}
diff --git a/mrouted.service b/mrouted.service
index e7c4a5eb97b9..8c8935b83cb6 100644
--- a/mrouted.service
+++ b/mrouted.service
@@ -2,12 +2,11 @@
Description=Multicast Route Daemon
After=network.target
ConditionPathExists=/etc/mrouted.conf
-Conflicts=pimd.service smcroute.service
[Service]
Type=forking
PIDFile=/var/run/mrouted.pid
-ExecStart=/usr/bin/mrouted
+ExecStart=/usr/sbin/mrouted
ExecReload=/bin/kill -HUP $MAINPID
Restart=on-abort