summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSelfRef2023-12-17 22:14:45 +0100
committerSelfRef2023-12-17 22:14:45 +0100
commit68cb476aa514be8f89a51b2dfcdc4e1f0539487b (patch)
treee9948b7d2f378800ee7ae8cdc317a436d9c5f49e
downloadaur-68cb476aa514be8f89a51b2dfcdc4e1f0539487b.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fcfb50b1fc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mrpack-install
+ pkgdesc = Modrinth Modpack server deployment
+ pkgver = 0.16.9
+ pkgrel = 1
+ url = https://github.com/nothub/mrpack-install
+ arch = any
+ license = MIT
+ makedepends = go
+ source = mrpack-install::git+https://github.com/nothub/mrpack-install.git#tag=v0.16.9
+ md5sums = SKIP
+
+pkgname = mrpack-install
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8f9f1c067aa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!PKGBUILD
+!.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70ff57c75c7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: SelfRef <arch@selfref.dev>
+
+_basename=mrpack-install
+pkgname="${_basename}"
+pkgver=0.16.9
+pkgrel=1
+pkgdesc="Modrinth Modpack server deployment"
+arch=('any')
+url="https://github.com/nothub/mrpack-install"
+license=('MIT')
+makedepends=('go')
+source=("${_basename}"::"git+https://github.com/nothub/mrpack-install.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "$_basename"
+ make
+}
+
+package() {
+ install -Dm755 -t "${pkgdir}/usr/bin" "${_basename}/out/mrpack-install"
+} \ No newline at end of file