summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormajor major2019-03-11 15:42:33 +0100
committermajor major2019-03-11 15:42:33 +0100
commit9948fcd1615140215ad0151f58d8081282ebbc83 (patch)
tree664feff2fc417ced5ef05b790b46ef19ca629145
parent42157bd25cddab6819c54e9ee744340f4c8d9c07 (diff)
downloadaur-9948fcd1615140215ad0151f58d8081282ebbc83.tar.gz
added patches for finding Numpy correctly
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c1fab2763f3..11731bcdc09f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mrpt
pkgdesc = Provides an extensive set of libraries, algorithms, and applications employed in a number of mobile robotics research areas.
- pkgver = 1.5.5
+ pkgver = 1.5.6
pkgrel = 1
url = http://www.mrpt.org
install = mrpt.install
@@ -22,8 +22,12 @@ pkgbase = mrpt
optdepends = libusb: Kinect support
optdepends = pcl
optdepends = assimp
- source = mrpt-1.5.5::git+https://github.com/MRPT/mrpt.git#tag=1.5.5
+ source = mrpt-1.5.6::git+https://github.com/MRPT/mrpt.git#tag=1.5.6
+ source = https://raw.githubusercontent.com/majorx234/mrpt_patch/master/mrpt_CmakeLists.patch
+ source = https://raw.githubusercontent.com/majorx234/FindNumPy.cmake/master/FindNumPy.cmake
md5sums = SKIP
+ md5sums = 4c755c5fecd2f6bca94b02cf2695bcc1c06bd11d34a85f7b2a90bc9f1ebdf4c7
+ md5sums = e8cbe6841595d594659d9a16464af2386efd0dce2947e8f348e2c47fad1d022f
pkgname = mrpt
diff --git a/PKGBUILD b/PKGBUILD
index 0e8dab822bf0..b3157dfde456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mrpt
-pkgver=1.5.5
+pkgver=1.5.6
pkgrel=1
pkgdesc="Provides an extensive set of libraries, algorithms, and applications employed in a number of mobile robotics research areas."
arch=('i686' 'x86_64' 'armv7h')
@@ -14,8 +14,18 @@ install=mrpt.install
_dir=${pkgname}-${pkgver}
_tag=${pkgver}
-source=("${_dir}"::"git+https://github.com/MRPT/mrpt.git"#tag=${_tag})
-md5sums=('SKIP')
+source=("${_dir}"::"git+https://github.com/MRPT/mrpt.git"#tag=${_tag}
+ "https://raw.githubusercontent.com/majorx234/mrpt_patch/master/mrpt_CmakeLists.patch"
+ "https://raw.githubusercontent.com/majorx234/FindNumPy.cmake/master/FindNumPy.cmake")
+md5sums=('SKIP'
+ '4c755c5fecd2f6bca94b02cf2695bcc1c06bd11d34a85f7b2a90bc9f1ebdf4c7'
+ 'e8cbe6841595d594659d9a16464af2386efd0dce2947e8f348e2c47fad1d022f')
+
+prepare() {
+ cp ${srcdir}/FindNumPy.cmake ${srcdir}/$pkgname-$pkgver/cmakemodules/
+ cd "${srcdir}/$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/mrpt_CmakeLists.patch"
+}
build() {
# Create build directory