diff options
author | begin-theadventure | 2023-07-18 19:36:53 +0200 |
---|---|---|
committer | begin-theadventure | 2023-07-18 19:36:53 +0200 |
commit | e2005cb796fb89b0d77c8b0382229cd47a8063cd (patch) | |
tree | f4af54b7de4b610fba0e9878a7a40825bd1904fa | |
parent | faedfc9718c95fe09048692ff4572774d7835b42 (diff) | |
download | aur-e2005cb796fb89b0d77c8b0382229cd47a8063cd.tar.gz |
Edit desktop creation
-rw-r--r-- | PKGBUILD | 20 |
1 files changed, 10 insertions, 10 deletions
@@ -11,7 +11,6 @@ license=('BSD' 'GPL' 'LGPL') provides=($_pkgname) conflicts=($_pkgname) noextract=("$_pkgname-$pkgver-$pkgrel.zip") -_desktop=mrvn-radiant.desktop _actions=5231536939 _number=2023-06-10_5f02305 source=("$_pkgname-$pkgver-$pkgrel.zip::https://nightly.link/MRVN-Radiant/MRVN-Radiant/actions/runs/$_actions/MRVN-Radiant_${_number}_Linux_x86_64.zip") @@ -19,14 +18,15 @@ sha256sums=('1949f665f5af7cf5fd74973f5d2bb12f4d931b31eb9111d39bbcd73330407f68') prepare() { # Create a shortcut - echo "Categories=Utilities;" > $_desktop - sed -i '1 i\Comment=Fork of netradiant-custom modified for Titanfall and Apex Legends mapping' $_desktop - sed -i '1 i\Icon=/opt/mrvn-radiant/bitmaps/splash.png' $_desktop - sed -i '1 i\Type=Application' $_desktop - sed -i '1 i\Terminal=false' $_desktop - sed -i '1 i\Exec=mrvn-radiant %U' $_desktop - sed -i '1 i\Name=MRVN Radiant' $_desktop - sed -i '1 i\[Desktop Entry]' $_desktop + echo "Categories=Utilities;" > desktop + sed -i '1 i\Comment=Fork of netradiant-custom modified for Titanfall and Apex Legends mapping' desktop + sed -i '1 i\Icon=/opt/mrvn-radiant/bitmaps/splash.png' desktop + sed -i '1 i\Type=Application' desktop + sed -i '1 i\Terminal=false' desktop + sed -i '1 i\Exec=mrvn-radiant %U' desktop + sed -i '1 i\Name=MRVN Radiant' desktop + sed -i '1 i\[Desktop Entry]' desktop + mv desktop $_pkgname.desktop # Unzip unzip -od $_pkgname-$pkgver-$pkgrel $_pkgname-$pkgver-$pkgrel.zip # Make the binary executable @@ -39,5 +39,5 @@ package() { # Install cp -r $_pkgname-$pkgver-$pkgrel/* "$pkgdir/opt/$_pkgname" ln -s /opt/$_pkgname/radiant "$pkgdir/usr/bin/$_pkgname" - install -Dm644 $_desktop -t "$pkgdir/usr/share/applications" + install -Dm644 $_pkgname.desktop -t "$pkgdir/usr/share/applications" } |