summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Vybíhal2019-09-11 09:11:49 +0200
committerJosef Vybíhal2019-09-11 09:11:49 +0200
commitf30cb4fe01e8aa0505f27669fd62fa8e8878b179 (patch)
tree4550e5e1f06a6ac25a9adad2427186af330137c3
downloadaur-f30cb4fe01e8aa0505f27669fd62fa8e8878b179.tar.gz
Initial commit of ms-teams for AUR
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD23
-rw-r--r--ms-teams.install35
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7f317c45934
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ms-teams
+ pkgdesc = Microsoft Teams for Linux is your chat-centered workspace in Office 365
+ pkgver = 1.2.00.24756
+ pkgrel = 3
+ url = https://teams.microsoft.com/start
+ install = ms-teams.install
+ arch = x86_64
+ depends = gnome-keyring
+ depends = pango
+ depends = libsecret
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = cairo
+ depends = fontconfig
+ depends = dbus
+ depends = glib2
+ provides = ms-teams=1.2.00.24756
+ options = !emptydirs
+ options = !strip
+ source = teams-insiders_1.2.00.24756_amd64.deb::https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams-insiders/teams-insiders_1.2.00.24756_amd64.deb
+ sha256sums = 8daa8d8a52555a9839d575c8c49c87e542a7189e46017284d2e3ff2ec5c19259
+
+pkgname = ms-teams
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5fddfa1a44d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Josef Vybíhal (josef.vybihal@gmail.com)
+
+pkgname=ms-teams
+pkgver=1.2.00.24756
+pkgrel=1
+pkgdesc="Microsoft Teams for Linux is your chat-centered workspace in Office 365"
+arch=('x86_64')
+url="https://teams.microsoft.com/start"
+#license=('custom:ms-teams')
+depends=('gnome-keyring' 'pango' 'libsecret' 'gtk3' 'gdk-pixbuf2' 'cairo' 'fontconfig' 'dbus' 'glib2') #?? FIXME
+optdepends=()
+provides=("ms-teams=${pkgver}")
+options=('!emptydirs' '!strip')
+install=${pkgname}.install
+_source_arch="amd64"
+#[ "${CARCH}" = 'x86_64' ] && _source_arch="amd64"
+source=("teams-insiders_${pkgver}_${_source_arch}.deb::https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams-insiders/teams-insiders_${pkgver}_${_source_arch}.deb")
+sha256sums=('8daa8d8a52555a9839d575c8c49c87e542a7189e46017284d2e3ff2ec5c19259')
+
+package() {
+ msg2 "Extracting the data.tar.xz"
+ tar -xf data.tar.xz -C "${pkgdir}/"
+}
diff --git a/ms-teams.install b/ms-teams.install
new file mode 100644
index 000000000000..78a1bce3ecee
--- /dev/null
+++ b/ms-teams.install
@@ -0,0 +1,35 @@
+# Some colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+ msg_blue "Updating icon cache.."
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_install() {
+ _update
+ note "The binary is called 'teams-insider'."
+}
+
+
+post_upgrade() {
+ post_install
+}
+
+
+post_remove() {
+ _update
+} \ No newline at end of file