summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2015-06-14 15:38:57 +0300
committerLev Levitsky2015-06-14 15:38:57 +0300
commit53f7998342f1b4eae80dc93221e266bc70959475 (patch)
treee7b36cbd224b9bb7932b403be24214be61ec5f1e
downloadaur-53f7998342f1b4eae80dc93221e266bc70959475.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rwxr-xr-xmsamanda2
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73431fe2c0ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.1
+# Fri May 1 20:16:37 UTC 2015
+pkgbase = msamanda
+ pkgdesc = A scoring system to identify peptides out of tandem mass spectrometry data using a database of known proteins
+ pkgver = 1.0.0.4485
+ pkgrel = 1
+ url = http://ms.imp.ac.at/?goto=msamanda
+ arch = any
+ license = custom
+ depends = mono
+ noextract = MSAmanda_Standalone_LinuxMac_1.0.0.4485.tar.gz
+ source = http://ms.imp.ac.at/inc/pd-nodes/msamanda/MSAmanda_Standalone_LinuxMac_1.0.0.4485.tar.gz
+ source = LICENSE::http://ms.imp.ac.at/inc/pd-nodes/msamanda/LicenseAgreement_MSAmanda.rtf
+ source = msamanda
+ md5sums = 2144b367817474a553abf12cfe2e4c8d
+ md5sums = 7f0bf2c30c4d78b18a0138df20050abf
+ md5sums = a870877935f5aed33fd0a7ec73e5abca
+
+pkgname = msamanda
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7689e267021b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lev Levitsky <levlev@mail.ru>
+pkgname=msamanda
+pkgver=1.0.0.4485
+pkgrel=1
+pkgdesc="A scoring system to identify peptides out of tandem mass spectrometry data using a database of known proteins"
+arch=('any')
+url="http://ms.imp.ac.at/?goto=msamanda"
+license=('custom')
+depends=('mono')
+options=()
+source=("http://ms.imp.ac.at/inc/pd-nodes/msamanda/MSAmanda_Standalone_LinuxMac_$pkgver.tar.gz"
+ "LICENSE::http://ms.imp.ac.at/inc/pd-nodes/msamanda/LicenseAgreement_MSAmanda.rtf"
+ "msamanda")
+noextract=("MSAmanda_Standalone_LinuxMac_$pkgver.tar.gz")
+md5sums=('2144b367817474a553abf12cfe2e4c8d'
+ '7f0bf2c30c4d78b18a0138df20050abf'
+ 'a870877935f5aed33fd0a7ec73e5abca')
+
+prepare() {
+ mkdir "MSAmanda"
+ bsdtar -xf "MSAmanda_Standalone_LinuxMac_$pkgver.tar.gz" -C MSAmanda
+ chmod -R o+rx MSAmanda
+}
+
+package() {
+ mkdir "$pkgdir/opt"
+ cp -rt "$pkgdir/opt/" "$srcdir/MSAmanda"
+ install -D "$srcdir/msamanda" "$pkgdir/usr/bin/msamanda"
+ install -D "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/msamanda b/msamanda
new file mode 100755
index 000000000000..eb32c2f78492
--- /dev/null
+++ b/msamanda
@@ -0,0 +1,2 @@
+#!/usr/bin/sh
+mono /opt/MSAmanda/MSAmanda.exe "$@"