summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2019-07-19 16:45:31 +0200
committerFlorian Maunier2019-07-19 16:45:31 +0200
commit7f524abff659424d7f6db11375fbf00fb00c3fac (patch)
tree36874ae6117cf3d30a8b472740f9a1458dcabc9c
parent2325398ed262051596765255b48c089a3cb691c3 (diff)
downloadaur-7f524abff659424d7f6db11375fbf00fb00c3fac.tar.gz
upgrade to 16.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--fix-install.patch2
-rw-r--r--license-check-is-case-sensitive.patch58
4 files changed, 73 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 038515e384f3..80dd3ece2ff1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = msbuild
- pkgver = 16.0+xamarinxplat.2019.04.08.19.19
+ pkgver = 16.1+xamarinxplat.2019.06.05.11.19
pkgrel = 5
url = https://github.com/mono/msbuild
arch = x86_64
license = MIT
makedepends = unzip
- source = https://download.mono-project.com/sources/msbuild/msbuild-16.0+xamarinxplat.2019.04.08.19.19.tar.xz
+ source = https://download.mono-project.com/sources/msbuild/msbuild-16.1+xamarinxplat.2019.06.05.11.19.tar.xz
source = fix-install.patch
source = fixed-build-version.patch
- sha256sums = 0d425603281ae84d3cf560ea4f9e2b2159e7764f71406035070a7fe27878ec49
- sha256sums = d1bcae69de63a967514f47ddfcc5996b6d1ddb64f955270c42d48dd5407df2da
+ source = license-check-is-case-sensitive.patch
+ sha256sums = 8184b32f446aba5634342148c0d87a84073ee2ce160e325ae3a04d6b368b45e1
+ sha256sums = b6751be70a8c4d4cd7247da5f31663aa685ed7061a481319ef512ce1f7bb4518
sha256sums = 4acf88ec981bc687be8eb2aa7c000db21e6fb98fa68727c21cb6db3395f4b4df
+ sha256sums = 3a12a9c33ad5938e8af24d2985241053602f4efc94a4818a00a17da32ce4aba5
pkgname = msbuild
pkgdesc = Xamarin implementation of the Microsoft build system
diff --git a/PKGBUILD b/PKGBUILD
index 1dad77ce746a..1ca9897d92a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: jtmb <packaging at technologicalwizardry dot com>
pkgbase=msbuild
pkgname=('msbuild' 'msbuild-sdkresolver')
-pkgver=16.0+xamarinxplat.2019.04.08.19.19
+pkgver=16.1+xamarinxplat.2019.06.05.11.19
pkgrel=5
arch=('x86_64')
url="https://github.com/mono/msbuild"
@@ -10,15 +10,18 @@ license=('MIT')
makedepends=('unzip')
source=("https://download.mono-project.com/sources/msbuild/msbuild-${pkgver}.tar.xz"
'fix-install.patch'
- 'fixed-build-version.patch')
-sha256sums=('0d425603281ae84d3cf560ea4f9e2b2159e7764f71406035070a7fe27878ec49'
- 'd1bcae69de63a967514f47ddfcc5996b6d1ddb64f955270c42d48dd5407df2da'
- '4acf88ec981bc687be8eb2aa7c000db21e6fb98fa68727c21cb6db3395f4b4df')
+ 'fixed-build-version.patch'
+ 'license-check-is-case-sensitive.patch')
+sha256sums=('8184b32f446aba5634342148c0d87a84073ee2ce160e325ae3a04d6b368b45e1'
+ 'b6751be70a8c4d4cd7247da5f31663aa685ed7061a481319ef512ce1f7bb4518'
+ '4acf88ec981bc687be8eb2aa7c000db21e6fb98fa68727c21cb6db3395f4b4df'
+ '3a12a9c33ad5938e8af24d2985241053602f4efc94a4818a00a17da32ce4aba5')
prepare() {
cd "${pkgname}-${pkgver%+*}"
patch --forward --strip=1 --input="${srcdir}/fix-install.patch"
patch --forward --strip=1 --input="${srcdir}/fixed-build-version.patch"
+ patch --forward --strip=1 --input="${srcdir}/license-check-is-case-sensitive.patch"
}
build() {
diff --git a/fix-install.patch b/fix-install.patch
index f9143fe9432e..9af0979287a9 100644
--- a/fix-install.patch
+++ b/fix-install.patch
@@ -5,7 +5,7 @@ diff --unified --recursive --text msbuild.orig/mono/build/install.proj msbuild.n
<Exec
WorkingDirectory="$(XBuildDir)"
-- Command="ln -sfh Current 15.0" />
+- Command="ln -sfn Current 15.0" />
+ Command="ln -sfn $(TargetMSBuildToolsVersion) Current" />
<Exec
WorkingDirectory="$(MonoInstallPrefix)\lib\mono\msbuild"
diff --git a/license-check-is-case-sensitive.patch b/license-check-is-case-sensitive.patch
new file mode 100644
index 000000000000..a590dcb78ff3
--- /dev/null
+++ b/license-check-is-case-sensitive.patch
@@ -0,0 +1,58 @@
+Index: xamarin-pkg-msbuild/LICENSE
+===================================================================
+--- xamarin-pkg-msbuild.orig/LICENSE
++++ /dev/null
+@@ -1,24 +0,0 @@
+-The MIT License (MIT)
+-
+-Copyright (c) .NET Foundation and contributors
+-
+-All rights reserved.
+-
+-Permission is hereby granted, free of charge, to any person obtaining a copy
+-of this software and associated documentation files (the "Software"), to deal
+-in the Software without restriction, including without limitation the rights
+-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+-copies of the Software, and to permit persons to whom the Software is
+-furnished to do so, subject to the following conditions:
+-
+-The above copyright notice and this permission notice shall be included in all
+-copies or substantial portions of the Software.
+-
+-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+-SOFTWARE.
+-
+Index: xamarin-pkg-msbuild/license
+===================================================================
+--- /dev/null
++++ xamarin-pkg-msbuild/license
+@@ -0,0 +1,24 @@
++The MIT License (MIT)
++
++Copyright (c) .NET Foundation and contributors
++
++All rights reserved.
++
++Permission is hereby granted, free of charge, to any person obtaining a copy
++of this software and associated documentation files (the "Software"), to deal
++in the Software without restriction, including without limitation the rights
++to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
++copies of the Software, and to permit persons to whom the Software is
++furnished to do so, subject to the following conditions:
++
++The above copyright notice and this permission notice shall be included in all
++copies or substantial portions of the Software.
++
++THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
++AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
++OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
++SOFTWARE.
++