summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJunYoung Gwak2020-10-05 03:21:03 -0700
committerJunYoung Gwak2020-10-05 03:21:03 -0700
commitb0f84044f1edcb656d26c17fd3f00ff26ac5e87d (patch)
tree47e22b4c6fccfe75ec204cbe64845ec60a05a5bd
parentfe83001a9b845ff7b9950a643e006bea9002b380 (diff)
downloadaur-b0f84044f1edcb656d26c17fd3f00ff26ac5e87d.tar.gz
Improved formatting by relrel.
1. Updated pkgdesc to match how the website describes it: "ChromeDriver is a standalone server that implements the W3C WebDriver standard". 2. Changed license from Apache to BSD, per https://groups.google.com/a/chromium.org/g/chromium-discuss/c/H6y6eo2--ZI. 3. Removed unnecessary single quotes from depends, optdepends and conflicts= 4. Reordered the variables to match the order of https://git.archlinux.org/pacman.git/plain/proto/PKGBUILD.proto. 5. Used sha512sums instead of md5sums. 6. Simplified the package() function.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab932655d875..de97df3c43c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = chromedriver
- pkgdesc = Standalone server which implements WebDriver's wire protocol (for google-chrome)
+ pkgdesc = Standalone server that implements the W3C WebDriver standard (for google-chrome)
pkgver = 85.0.4183.87
pkgrel = 1
url = https://chromedriver.chromium.org/
arch = x86_64
- license = Apache
+ license = BSD
depends = alsa-lib
depends = gtk3
depends = libcups
@@ -15,7 +15,7 @@ pkgbase = chromedriver
optdepends = google-chrome
conflicts = chromium
source = chromedriver_85.0.4183.87_linux64.zip::https://chromedriver.storage.googleapis.com/85.0.4183.87/chromedriver_linux64.zip
- md5sums = 49513e90656c825f5acadfb917bb7840
+ sha512sums = 63fe706968abfd96f6cf5dd5a89efe84c01334ecec7cae5023a80b425c1b668ccabc48f6526c2bbb926bf7d7371ded39b9811c7098eee4fd09f8ff3ac3eb5c90
pkgname = chromedriver
diff --git a/PKGBUILD b/PKGBUILD
index 645bce92159f..0fd3074f297e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: JunYoung Gwak <aur@jgwak.com>
+# Contributor: relrel <relrelbachar@gmail.com>
# Contributor: grimsock <lord.grimsock at gmail dot com>
# Contributor: James An <james@jamesan.ca>
# Contributor: lybin
-
pkgname=chromedriver
pkgver=85.0.4183.87
pkgrel=1
-pkgdesc="Standalone server which implements WebDriver's wire protocol (for google-chrome)"
+pkgdesc="Standalone server that implements the W3C WebDriver standard (for google-chrome)"
arch=('x86_64')
url="https://chromedriver.chromium.org/"
-license=('Apache')
-conflicts=('chromium')
-depends=('alsa-lib' 'gtk3' 'libcups' 'libxss' 'libxtst' 'nss' 'xdg-utils')
-optdepends=('google-chrome')
-md5sums=('49513e90656c825f5acadfb917bb7840')
-
+license=('BSD')
+depends=(alsa-lib gtk3 libcups libxss libxtst nss xdg-utils)
+optdepends=(google-chrome)
+conflicts=(chromium)
source=("${pkgname}_${pkgver}_linux64.zip::https://chromedriver.storage.googleapis.com/${pkgver}/${pkgname}_linux64.zip")
+sha512sums=('63fe706968abfd96f6cf5dd5a89efe84c01334ecec7cae5023a80b425c1b668ccabc48f6526c2bbb926bf7d7371ded39b9811c7098eee4fd09f8ff3ac3eb5c90')
package() {
- mkdir -p "$pkgdir/usr/bin/"
- install -D -m 755 "$srcdir/$pkgname" "$pkgdir/usr/bin/"
+ install -Dm755 -t "$pkgdir/usr/bin/" "$srcdir/$pkgname"
}