summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2018-02-26 13:14:12 +0300
committerLev Levitsky2018-02-26 13:14:12 +0300
commit3713fa5c78771dbf5217ae06d971c490934b97d8 (patch)
tree00ed56610ac16f031cbf5c57b4a82cebfbb148f2
parentc3d1576d331e7aff6715bcccb3760b2e56601866 (diff)
downloadaur-3713fa5c78771dbf5217ae06d971c490934b97d8.tar.gz
New release, add license, tweak dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e636d602593..b855c68e04a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = msgfplus
pkgdesc = MS/MS database search tool
- pkgver = 2017.08.23
+ pkgver = 2018.01.30
pkgrel = 1
url = https://github.com/sangtaekim/msgfplus
arch = any
license = custom
- depends = java-runtime
- source = https://github.com/sangtaekim/msgfplus/releases/download/v2017.08.23/MSGFPlus.zip
+ depends = java-environment
+ source = https://github.com/sangtaekim/msgfplus/releases/download/v2018.01.30/v20180130.zip
source = msgf+
source = mzid2tsv
- md5sums = 08557a69a65366df26b0250c5508f894
+ source = https://raw.githubusercontent.com/sangtaekim/msgfplus/master/LICENSE.txt
+ md5sums = 8ed7345ced1abf41e632afd60831a55a
md5sums = c43c6581b373266171c3930c3718eb9c
md5sums = c860b9c30b74dae43de2d3933a405ac1
+ md5sums = SKIP
pkgname = msgfplus
diff --git a/PKGBUILD b/PKGBUILD
index 3c5222c429a2..fd010b90b8ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Lev Levitsky <levlev@mail.ru>
pkgname=msgfplus
-pkgver=2017.08.23
+pkgver=2018.01.30
pkgrel=1
pkgdesc="MS/MS database search tool"
arch=('any')
url="https://github.com/sangtaekim/msgfplus"
license=('custom')
-depends=('java-runtime')
-source=("https://github.com/sangtaekim/msgfplus/releases/download/v${pkgver}/MSGFPlus.zip"
+depends=('java-environment')
+source=("https://github.com/sangtaekim/msgfplus/releases/download/v${pkgver}/v${pkgver//./}.zip"
"msgf+"
- "mzid2tsv")
-md5sums=('08557a69a65366df26b0250c5508f894'
+ "mzid2tsv"
+ "https://raw.githubusercontent.com/sangtaekim/msgfplus/master/LICENSE.txt")
+md5sums=('8ed7345ced1abf41e632afd60831a55a'
'c43c6581b373266171c3930c3718eb9c'
- 'c860b9c30b74dae43de2d3933a405ac1')
+ 'c860b9c30b74dae43de2d3933a405ac1'
+ 'SKIP')
package() {
-cd "$srcdir"
+ cd "$srcdir"
install -D MSGFPlus.jar "${pkgdir}/usr/share/java/${pkgname}/MSGFPlus.jar"
mkdir -p "${pkgdir}/usr/share/${pkgname}"
cp -r doc/examples "${pkgdir}/usr/share/${pkgname}/"
install -D msgf+ "${pkgdir}/usr/bin/msgf+"
install -D mzid2tsv "${pkgdir}/usr/bin/mzid2tsv"
+ install -D LICENSE.txt -t "${pkgdir}/usr/share/licenses/msgfplus/"
}