summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2020-06-19 03:03:07 +0300
committerLev Levitsky2020-06-19 03:03:07 +0300
commitdd5e29bad134f5d81bab33fb6729ad060a33f7f5 (patch)
tree88f9771ade79f9d8fe54773ba674ff6498c930f2
parent8925ca04e83ff33a61e7e98ff8caa72b3ebb6f1d (diff)
downloadaur-dd5e29bad134f5d81bab33fb6729ad060a33f7f5.tar.gz
Use maven build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 347034b34785..7367c547d932 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = msgfplus
pkgdesc = MS/MS database search tool
pkgver = 2020.06.16
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MSGFPlus/msgfplus
arch = any
license = custom
+ makedepends = maven
depends = java-environment
- source = https://github.com/MSGFPlus/msgfplus/releases/download/v2020.06.16/MSGFPlus_v20200616.zip
+ source = https://github.com/MSGFPlus/msgfplus/archive/v2020.06.16.zip
source = msgf+
source = mzid2tsv
source = scoringParamGen
source = https://raw.githubusercontent.com/sangtaekim/msgfplus/master/LICENSE.txt
- md5sums = 6c67550069a466c03244adb855bcc225
+ md5sums = 37eae92f385e2f4ec7c4a2182f25c56e
md5sums = c43c6581b373266171c3930c3718eb9c
md5sums = c860b9c30b74dae43de2d3933a405ac1
md5sums = 315d84069d6333a83599aa93b782eb5c
diff --git a/PKGBUILD b/PKGBUILD
index 7fde561cfa75..6b9b2bff0bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,34 @@
# Maintainer: Lev Levitsky <levlev@mail.ru>
pkgname=msgfplus
pkgver=2020.06.16
-pkgrel=1
+pkgrel=2
pkgdesc="MS/MS database search tool"
arch=('any')
url="https://github.com/MSGFPlus/msgfplus"
license=('custom')
depends=('java-environment')
-source=("https://github.com/MSGFPlus/msgfplus/releases/download/v${pkgver}/MSGFPlus_v${pkgver//./}.zip"
+makedepends=('maven')
+source=("https://github.com/MSGFPlus/msgfplus/archive/v${pkgver}.zip"
"msgf+"
"mzid2tsv"
"scoringParamGen"
"https://raw.githubusercontent.com/sangtaekim/msgfplus/master/LICENSE.txt")
-md5sums=('6c67550069a466c03244adb855bcc225'
+md5sums=('37eae92f385e2f4ec7c4a2182f25c56e'
'c43c6581b373266171c3930c3718eb9c'
'c860b9c30b74dae43de2d3933a405ac1'
'315d84069d6333a83599aa93b782eb5c'
'88b22e0922010401ea88bcf03e3bb5d2')
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mvn package
+}
+
package() {
cd "$srcdir"
- install -D MSGFPlus.jar "${pkgdir}/usr/share/java/${pkgname}/MSGFPlus.jar"
+ install -D "${pkgname}-${pkgver}/target/MSGFPlus.jar" "${pkgdir}/usr/share/java/${pkgname}/MSGFPlus.jar"
mkdir -p "${pkgdir}/usr/share/${pkgname}"
- cp -r Docs/Examples "${pkgdir}/usr/share/${pkgname}/"
+ cp -r "${pkgname}-${pkgver}/docs/examples" "${pkgdir}/usr/share/${pkgname}/"
install -D msgf+ "${pkgdir}/usr/bin/msgf+"
install -D mzid2tsv "${pkgdir}/usr/bin/mzid2tsv"
install -D scoringParamGen "${pkgdir}/usr/bin/scoringParamGen"