summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Fraser2016-05-29 15:23:17 -0400
committerNicholas Fraser2016-05-29 15:23:17 -0400
commit56687cbafa431fa83ccfec1c34eb635da576b657 (patch)
tree3cd585de9706d79c093b56d954c451d7a5d41320
downloadaur-56687cbafa431fa83ccfec1c34eb635da576b657.tar.gz
Initial PKGBUILD, msgpack-tools version 0.4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3734b19937dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = msgpack-tools
+ pkgdesc = Command-line tools for converting between MessagePack and JSON
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/ludocode/msgpack-tools
+ arch = i686
+ arch = x86_64
+ arch = mips64el
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ arch = aarch64
+ license = MIT
+ makedepends = cmake
+ depends = gcc-libs
+ source = https://github.com/ludocode/msgpack-tools/releases/download/v0.4/msgpack-tools-0.4.tar.gz
+ sha256sums = 6ca77477ed47ccf4ac882ace3ee5f33a7bc7b929d12c5f10fa0c8fb5874fbc10
+
+pkgname = msgpack-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f20a69f52a1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nicholas Fraser <nicholas.rd.fraser@gmail.com>
+pkgname=msgpack-tools
+pkgver=0.4
+pkgrel=1
+pkgdesc="Command-line tools for converting between MessagePack and JSON"
+arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
+url="https://github.com/ludocode/msgpack-tools"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('cmake')
+source=(https://github.com/ludocode/msgpack-tools/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('6ca77477ed47ccf4ac882ace3ee5f33a7bc7b929d12c5f10fa0c8fb5874fbc10')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}