summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorericek1112021-09-03 18:25:56 +0200
committerericek1112021-09-03 18:25:56 +0200
commit03c2f2eb0fdb7502a75c784723c1a6181c90e310 (patch)
tree96049e4ab88d59f33c031a256be4740fa987c579
parent5d4c9ee0a823a094edd6308755323725c8383d48 (diff)
downloadaur-03c2f2eb0fdb7502a75c784723c1a6181c90e310.tar.gz
fix PulseAudio sound card enumeration with no ALSA present
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--pa_with_no_alsa.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db3c2cf8b8c4..5dd6d531c3ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mshv
pkgdesc = Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65.
pkgver = 258
- pkgrel = 3
+ pkgrel = 4
url = http://lz2hv.org/mshv
arch = any
license = GPL3
@@ -17,9 +17,11 @@ pkgbase = mshv
source = mshv_launcher.sh
source = mshv.desktop
source = flrigxml.patch
+ source = pa_with_no_alsa.patch
sha256sums = 039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d
sha256sums = 5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab
sha256sums = 85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba
sha256sums = 22de199636d17912738651eba8db6b5ccf7cecae816dcddee6d46a33d585f8ca
+ sha256sums = 6d021299b6970e262f73749e2e3b4c859cb5a0f36e19dfd44a0a6924dcc0d7d9
pkgname = mshv
diff --git a/PKGBUILD b/PKGBUILD
index 811d31118ac9..ec07f6dd8fde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mshv
pkgver=258
-pkgrel=3
+pkgrel=4
pkgdesc="Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65."
arch=('any')
url="http://lz2hv.org/mshv"
@@ -16,16 +16,19 @@ source=(
"mshv_launcher.sh"
"mshv.desktop"
"flrigxml.patch"
+ "pa_with_no_alsa.patch"
)
sha256sums=(
'039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d'
'5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab'
'85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba'
'22de199636d17912738651eba8db6b5ccf7cecae816dcddee6d46a33d585f8ca'
+ '6d021299b6970e262f73749e2e3b4c859cb5a0f36e19dfd44a0a6924dcc0d7d9'
)
prepare() {
patch --directory="$srcdir/MSHV_$pkgver" --forward --strip=1 --input="$srcdir/flrigxml.patch"
+ patch --directory="$srcdir/MSHV_$pkgver" --forward --strip=1 --input="$srcdir/pa_with_no_alsa.patch"
}
build() {
diff --git a/pa_with_no_alsa.patch b/pa_with_no_alsa.patch
new file mode 100644
index 000000000000..edf1161f1669
--- /dev/null
+++ b/pa_with_no_alsa.patch
@@ -0,0 +1,12 @@
+diff --color --unified --recursive --text package.old/src/SettingsMs/settings_ms.cpp package.new/src/SettingsMs/settings_ms.cpp
+--- package.old/src/SettingsMs/settings_ms.cpp 2021-09-03 18:22:57.689795799 +0200
++++ package.new/src/SettingsMs/settings_ms.cpp 2021-09-03 18:23:10.849795604 +0200
+@@ -529,7 +529,7 @@
+ break;
+ }
+ }
+- if (!lst_f.isEmpty())
++ if (true)
+ {
+
+ DevBoxAlsa->addItems(lst_f);