summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Pulzer2015-12-17 15:26:33 +0100
committerThomas Pulzer2015-12-17 15:26:33 +0100
commit10c0d17d8b1c0bd41e74dcd6e9d13da9ed20c56a (patch)
treea6447d711b15b43aa6242815c1176d84410e1383
downloadaur-10c0d17d8b1c0bd41e74dcd6e9d13da9ed20c56a.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d6fa8a809df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Dec 17 14:22:57 UTC 2015
+pkgbase = msigna
+ pkgdesc = An interactive desktop application for transacting on the bitcoin network.
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = https://ciphrex.com
+ arch = x86_64
+ arch = i686
+ license = AGPL3
+ license = MIT
+ makedepends = qt5-base
+ makedepends = boost-libs
+ makedepends = libodb-sqlite
+ makedepends = qrencode
+ depends = qt5-base
+ depends = boost-libs
+ depends = libodb-sqlite
+ depends = qrencode
+ optdepends = bitcoin-qt
+ source = https://github.com/Faldon/mSIGNA/archive/v0.9.6-AUR.tar.gz
+ md5sums = bc4323729906ce76b8600065189c762e
+
+pkgname = msigna
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4ea4f28e4dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Thomas Pulzer <t.pulzer at thesecretgamer dot de>
+pkgname=msigna
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="An interactive desktop application for transacting on the bitcoin network."
+arch=('x86_64' 'i686')
+url="https://ciphrex.com"
+license=('AGPL3' 'MIT')
+depends=('qt5-base' 'boost-libs' 'libodb-sqlite' 'qrencode')
+makedepends=('qt5-base' 'boost-libs' 'libodb-sqlite' 'qrencode')
+optdepends=('bitcoin-qt')
+source=("https://github.com/Faldon/mSIGNA/archive/v$pkgver-AUR.tar.gz")
+
+prepare() {
+ cd "$srcdir/mSIGNA-$pkgver-AUR"
+ sed -i -e "s#PREFIX=#PREFIX=$pkgdir/usr#g" build-all.sh
+ sed -i -e "s#VERSION=#VERSION=$pkgver#g" "mSIGNA.desktop"
+ sed -i -e "s#COMMENT=#COMMENT=$pkgdesc#g" "mSIGNA.desktop"
+}
+
+build() {
+ cd "mSIGNA-$pkgver-AUR"
+ ./build-all.sh linux
+}
+
+package() {
+ cd "mSIGNA-$pkgver-AUR"
+ make install
+}
+md5sums=('bc4323729906ce76b8600065189c762e')