summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Horky2019-10-29 16:22:49 +0100
committerVojtech Horky2019-10-29 16:22:49 +0100
commitd206c7ff50300c7347867dbbbccb2a54050d1ea7 (patch)
treec04833674582f24fbcfd7b17e41eae0c7aa17e60
downloadaur-msim-git.tar.gz
Initial upload: msim-git 0443c37-1
Add msim-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95aa4708a3f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = msim-git
+ pkgdesc = Light-weight computer simulator based on MIPS R4000
+ pkgver = 0443c37
+ pkgrel = 1
+ url = http://dsrg.mff.cuni.cz/~holub/sw/msim/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = imake
+ depends = readline
+ provides = msim
+ conflicts = msim
+ source = msim-git::git://github.com/D-iii-S/msim.git
+ md5sums = SKIP
+
+pkgname = msim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d03fd45d2b32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Vojtech Horky <AUR / hotspur>
+pkgname=msim-git
+pkgver=0443c37
+pkgrel=1
+pkgdesc="Light-weight computer simulator based on MIPS R4000"
+url="http://dsrg.mff.cuni.cz/~holub/sw/msim/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('readline')
+makedepends=('imake')
+provides=('msim')
+conflicts=('msim')
+source=("$pkgname"::'git://github.com/D-iii-S/msim.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ # Use the tag of the last commit
+ git describe --always --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make "DESTDIR=${pkgdir}" install
+ msg "Installing documentation"
+ install -d -m 0755 "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/"
+ install -m 0644 doc/reference.html doc/default.css \
+ "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/"
+}