summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLPB6122019-04-04 22:12:13 -0500
committerLPB6122019-04-04 22:12:13 -0500
commitfd391fcb892203659593c948bbe80354bee3f53a (patch)
tree02f1868b47ee738b2faf7fbea91b10ed988f1542
parent59b02687fcd4b9263c6f46f170c78cabe71d727f (diff)
downloadaur-fd391fcb892203659593c948bbe80354bee3f53a.tar.gz
added source file get-gmail-token
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84fc9e4cc93d..7cd456f3b704 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Eric BĂ©langer <eric@archlinux.org>
pkgbase=msmtp-oauth2
+_pkgbase=msmtp
pkgname=('msmtp-oauth2')
conflicts=('msmtp')
pkgver=1.8.3
@@ -11,11 +12,13 @@ arch=('x86_64')
url="https://marlam.de/msmtp/"
license=('GPL3')
makedepends=('texlive-plainextra' 'libsecret' 'gsasl')
-source=("https://marlam.de/msmtp/releases/msmtp-$pkgver.tar.xz")
-sha256sums=('3cb2eefd33d048f0f82de100ef39a494e44fd1485e376ead31f733d2f36b92b4')
+source=("https://marlam.de/msmtp/releases/msmtp-$pkgver.tar.xz"
+ get-gmail-token)
+sha256sums=('3cb2eefd33d048f0f82de100ef39a494e44fd1485e376ead31f733d2f36b92b4'
+SKIP)
build() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --with-libgsasl
make
make -C doc html pdf
@@ -25,7 +28,7 @@ package_msmtp-oauth2() {
pkgdesc="A mini smtp client, with oauth2 hack"
depends=('libsecret' 'gsasl' 'getmail')
- cd $pkgbase-$pkgver/src
+ cd $_pkgbase-$pkgver/src
sed -i '/"AUTH PLAIN %s", outbuf/{
s/PLAIN/XOAUTH2/
s/outbuf/password/