summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2016-01-27 18:29:18 -0500
committervonPalitroque2016-01-27 18:29:18 -0500
commit58a9581ef82a008b46b6ceed10ab98539348d4d3 (patch)
tree80ac4b18fb65f312be5721f03cb1cc2a206dec75
parentfbdba0d39e2a2e2bfea5380ca91339863eb1f932 (diff)
downloadaur-58a9581ef82a008b46b6ceed10ab98539348d4d3.tar.gz
Updated to binutils 2.26.
Updated to binutils 2.26. Added patch to fix dwarf line numbers. See [1] and [2] for details. [1] https://sourceware.org/ml/binutils/2016-01/msg00299.html [2] https://sourceware.org/ml/binutils/2016-01/msg00304.html
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--dwarf-line-fix.patch10
3 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d11c422f97df..eaa3769591b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 9 19:23:52 UTC 2015
+# Wed Jan 27 23:28:29 UTC 2016
pkgbase = msp430-elf-binutils
pkgdesc = GNU binary utilities for the msp430-elf target.
- pkgver = 2.25.1
- pkgrel = 3
+ pkgver = 2.26
+ pkgrel = 1
url = http://www.gnu.org/software/binutils/
arch = i686
arch = x86_64
@@ -12,12 +12,10 @@ pkgbase = msp430-elf-binutils
depends = flex
options = !libtool
options = !buildflags
- source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.25.1.tar.bz2
- source = bfd-fix.patch
- source = tc-msp430.c.patch
- sha256sums = b5b14added7d78a8d1ca70b5cb75fef57ce2197264f4f5835326b0df22ac9f22
- sha256sums = 1b5e879dbd9da83a8c7f86abac5cf706b8ba48e3f0525d893a53c651e4015124
- sha256sums = af639e72b33ce9a6b9f2fcb13355d27d7425f94a6fbefa3d0a377932a6786985
+ source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.26.tar.bz2
+ source = dwarf-line-fix.patch
+ sha256sums = c2ace41809542f5237afc7e3b8f32bb92bc7bc53c6232a84463c423b0714ecd9
+ sha256sums = 465964bd2ebf5a7eea340c1e145b3e01bb9da4aa2d9e7d24f8d18a3d2473e2af
pkgname = msp430-elf-binutils
diff --git a/PKGBUILD b/PKGBUILD
index 0685194614f6..83cdf3086efb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
_target=msp430-elf
pkgname=${_target}-binutils #-git
-_pkgver=2.25.1
+_pkgver=2.26
pkgver=${_pkgver}
#pkgver=2.25.r84308.c576455
-pkgrel=3
+pkgrel=1
pkgdesc="GNU binary utilities for the ${_target} target."
arch=(i686 x86_64)
options=('!libtool' '!buildflags')
@@ -21,11 +21,9 @@ depends=('zlib' 'flex')
# build from source
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2
- bfd-fix.patch
- tc-msp430.c.patch)
-sha256sums=('b5b14added7d78a8d1ca70b5cb75fef57ce2197264f4f5835326b0df22ac9f22'
- '1b5e879dbd9da83a8c7f86abac5cf706b8ba48e3f0525d893a53c651e4015124'
- 'af639e72b33ce9a6b9f2fcb13355d27d7425f94a6fbefa3d0a377932a6786985')
+ dwarf-line-fix.patch)
+sha256sums=('c2ace41809542f5237afc7e3b8f32bb92bc7bc53c6232a84463c423b0714ecd9'
+ '465964bd2ebf5a7eea340c1e145b3e01bb9da4aa2d9e7d24f8d18a3d2473e2af')
# pkgver() {
# cd "${srcdir}/binutils-${_pkgver}"
@@ -36,13 +34,12 @@ sha256sums=('b5b14added7d78a8d1ca70b5cb75fef57ce2197264f4f5835326b0df22ac9f22'
prepare() {
cd "${srcdir}/binutils-${_pkgver}"
- # https://sourceware.org/bugzilla/show_bug.cgi?id=17940
- patch -p1 < ../bfd-fix.patch
- # update list of known MCU names
- # https://sourceware.org/ml/binutils-cvs/2015-10/msg00074.html
- # the list has to be in sync with gcc
- patch -p1 < ../tc-msp430.c.patch
-
+ # fix for
+ # https://sourceware.org/ml/binutils/2016-01/msg00299.html
+ # found in
+ # https://sourceware.org/ml/binutils/2016-01/msg00304.html
+ patch -p1 < ../dwarf-line-fix.patch
+
# ensure a clean build
[[ -d binutils-build ]] && rm -rf binutils-build
mkdir binutils-build
diff --git a/dwarf-line-fix.patch b/dwarf-line-fix.patch
new file mode 100644
index 000000000000..a5d322fba061
--- /dev/null
+++ b/dwarf-line-fix.patch
@@ -0,0 +1,10 @@
+diff --git a/gas/config/tc-msp430.h b/gas/config/tc-msp430.h
+index 4a02452..86c9117 100644
+--- a/gas/config/tc-msp430.h
++++ b/gas/config/tc-msp430.h
+@@ -171,3 +171,5 @@ extern bfd_boolean msp430_allow_local_subtract (expressionS *, expressionS *, se
+#define DWARF2_USE_FIXED_ADVANCE_PC 1
+
+#define TC_LINKRELAX_FIXUP(seg) ((seg->flags & SEC_CODE) || (seg->flags & SEC_DEBUGGING))
++
++#define DWARF2_ADDR_SIZE(bfd) 4