summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2020-05-15 18:42:48 -0400
committervonPalitroque2020-05-15 18:42:48 -0400
commit874d9368acc5698eab8977025fa3ee62313d3c4c (patch)
treebc625183502398b537e149e322cb4275e9294a04
parentb620a94f4bbc995ca3e5835adccd16c35121d985 (diff)
downloadaur-874d9368acc5698eab8977025fa3ee62313d3c4c.tar.gz
Updated to latest upstream version.
Updated to latest upstream version.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--gcc-use-init_array-if-needed.patch31
3 files changed, 6 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0772d772573..5dffe18df23d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = msp430-elf-gcc
pkgdesc = The GNU Compiler Collection for the msp430-elf target.
- pkgver = 9.3.0
+ pkgver = 10.1.0
pkgrel = 1
url = http://gcc.gnu.org
arch = i686
@@ -24,11 +24,9 @@ pkgbase = msp430-elf-gcc
options = docs
options = !strip
source = http://isl.gforge.inria.fr/isl-0.22.1.tar.xz
- source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-9.3.0/gcc-9.3.0.tar.xz
- source = gcc-use-init_array-if-needed.patch
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-10.1.0/gcc-10.1.0.tar.xz
sha256sums = 28658ce0f0bdb95b51fd2eb15df24211c53284f6ca2ac5e897acc3169e55b60f
- sha256sums = 71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
- sha256sums = 4dcec95ee660b2db78e8aaac6cfda48f6d10c3d016058514603b816819e722eb
+ sha256sums = b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2
pkgname = msp430-elf-gcc
diff --git a/PKGBUILD b/PKGBUILD
index b3188512d473..2ca7696d8541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target="msp430-elf"
pkgname=${_target}-gcc
-pkgver=9.3.0
+pkgver=10.1.0
_islver=0.22.1
pkgrel=1
pkgdesc="The GNU Compiler Collection for the ${_target} target."
@@ -16,11 +16,9 @@ replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1")
optdepends=("${_target}-libstdc++: C++ standard library support")
source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.xz
- ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz
- gcc-use-init_array-if-needed.patch)
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz)
sha256sums=('28658ce0f0bdb95b51fd2eb15df24211c53284f6ca2ac5e897acc3169e55b60f'
- '71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1'
- '4dcec95ee660b2db78e8aaac6cfda48f6d10c3d016058514603b816819e722eb')
+ 'b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2')
prepare() {
@@ -30,14 +28,6 @@ prepare() {
[[ -d gcc-build ]] && rm -rf gcc-build
mkdir gcc-build
-
- # From newlib 3.2.0 onwards, .init_array is used only if the required symbols
- # are defined by gas. This functionality already exists in the current
- # binutils (2.33.1) and is part of GCC 10. The idea is to be able to run the
- # linker with --gc-sections and rid of the binary of initialization code that
- # is not needed. The assembler gas will emit the necessary symbols if the
- # code is actually needed. Backport the patch to the GCC 9.x series.
- patch -p1 < ../gcc-use-init_array-if-needed.patch
}
build() {
diff --git a/gcc-use-init_array-if-needed.patch b/gcc-use-init_array-if-needed.patch
deleted file mode 100644
index 8e2700cb307c..000000000000
--- a/gcc-use-init_array-if-needed.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/gcc/config.gcc b/gcc/config.gcc
-index 446a852ffe1..17ed1b876a1 100644
---- a/gcc/config.gcc
-+++ b/gcc/config.gcc
-@@ -2503,6 +2503,13 @@ msp430*-*-*)
- cxx_target_objs="msp430-c.o"
- tmake_file="${tmake_file} msp430/t-msp430"
- extra_gcc_objs="driver-msp430.o"
-+ # Enable .init_array unless it has been explicitly disabled (e.g. if
-+ # the user is building using an old version of newlib.
-+ # The MSPABI mandates .init_array, and the Newlib CRT code since
-+ # mid-2019 expects it.
-+ if test x${disable_initfini_array} != xyes; then
-+ gcc_cv_initfini_array=yes
-+ fi
- ;;
- nds32*-*-*)
- target_cpu_default="0"
-diff --git a/gcc/config/msp430/msp430.h b/gcc/config/msp430/msp430.h
-index 1288b1a263d..ca7cf20e1d7 100644
---- a/gcc/config/msp430/msp430.h
-+++ b/gcc/config/msp430/msp430.h
-@@ -49,7 +49,7 @@ extern bool msp430x;
-
- /* -lgcc is included because crtend.o needs __mspabi_func_epilog_1. */
- #undef ENDFILE_SPEC
--#define ENDFILE_SPEC "%{!minrt:crtend.o%s} %{minrt:crtn-minrt.o%s}%{!minrt:crtn.o%s} -lgcc"
-+#define ENDFILE_SPEC "%{!minrt:crtend.o%s} %{minrt:%:if-exists(crtn-minrt.o%s)}%{!minrt:%:if-exists(crtn.o%s)} -lgcc"
-
- #define ASM_SPEC "-mP " /* Enable polymorphic instructions. */ \
- "%{mcpu=*:-mcpu=%*}%{!mcpu=*:%{mmcu=*:-mmcu=%*}} " /* Pass the CPU type on to the assembler. */ \