summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2019-09-25 11:44:50 -0400
committervonPalitroque2019-09-25 11:44:50 -0400
commita2bf3b08981b12ce5d913996755a990fe4c0b9c3 (patch)
treefcb754d8b27d5031108ff7b86ce4535a94419d64
parentfde6de5d4f4eb1f19554220b1052671faf278ccb (diff)
downloadaur-a2bf3b08981b12ce5d913996755a990fe4c0b9c3.tar.gz
Added optional dependency to C++ library.
Added optional dependency to C++ library.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b82dff7549be..ba3e53b576a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = msp430-elf-gcc
pkgdesc = The GNU Compiler Collection for the msp430-elf target.
pkgver = 9.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = msp430-elf-gcc
depends = libmpc
depends = elfutils
depends = zlib
+ optdepends = msp430-elf-libstdc++: C++ standard library support
provides = msp430-elf-gcc-stage1
conflicts = msp430-elf-gcc-stage1
replaces = msp430-elf-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index 78ecbd69eb85..4446dce48362 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _target="msp430-elf"
pkgname=${_target}-gcc
pkgver=9.2.0
_islver=0.21
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection for the ${_target} target."
arch=(i686 x86_64)
license=('GPL' 'LGPL')
@@ -14,6 +14,7 @@ options=('staticlibs' '!buildflags' '!libtool' '!emptydirs' 'zipman' 'docs' '!st
conflicts=("${_target}-gcc-stage1")
replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1")
+optdepends=("${_target}-libstdc++: C++ standard library support")
source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.xz
ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz)
sha256sums=('777058852a3db9500954361e294881214f6ecd4b594c00da5eee974cd6a54960'
@@ -48,7 +49,7 @@ build() {
--target=${_target} \
--host=$CHOST \
--build=$CHOST \
- --disable-shared \
+ --enable-shared \
--disable-nls \
--disable-threads \
--enable-languages=c,c++ \
@@ -61,7 +62,8 @@ build() {
--disable-libgomp \
--disable-libssp \
--enable-interwork \
- --enable-addons
+ --enable-addons \
+ --enable-lto
make all-gcc all-target-libgcc
}