summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadzim Dambrouski2018-12-23 13:11:49 +0000
committerVadzim Dambrouski2018-12-23 14:23:18 +0000
commit756c2a3187d211e44ab6fdff3a20fb831881e8bb (patch)
tree5587e5eac33f112f51e26878b8d8bc083aecf975
parenta049a7b7594e7d7f646a05a0ffa38c1e09729d58 (diff)
downloadaur-756c2a3187d211e44ab6fdff3a20fb831881e8bb.tar.gz
Update to 7.3.2.154
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12a4c5d9cf6..8f3ebbbec835 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = msp430-elf-gcc-bin
pkgdesc = GNU Tools for TI MSP430 microcontroller family (binary distribution, release 6_0_1_0)
- pkgver = 7.3.1.24
+ pkgver = 7.3.2.154
pkgrel = 1
url = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = msp430-elf-gcc-bin
conflicts = msp430-elf-newlib
options = !strip
options = staticlibs
- source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_0_1_0/exports/msp430-gcc-7.3.1.24_linux64.tar.bz2
- sha256sums = 13a362cb459ae510d1b41c074d72298be45a5b7fd53ae189c38fcfdb19bcd8ac
+ source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_1_0_0/exports/msp430-gcc-7.3.2.154_linux64.7z
+ sha256sums = a85007bd64ce4d1c4d4b52c60851cfd4bf3bc23783a0a5d5c2b8ef923ce766d8
pkgname = msp430-elf-gcc-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..493a61cb7345
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/*.pkg.tar.xz
+/*.tar.bz2
+/*.7z
diff --git a/PKGBUILD b/PKGBUILD
index f3f60663e192..89bc87bf7611 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Vadzim Dambrouski <pftbest gmail.com>
pkgname=msp430-elf-gcc-bin
-pkgver=7.3.1.24
+pkgver=7.3.2.154
pkgrel=1
pkgdesc="GNU Tools for TI MSP430 microcontroller family (binary distribution, release 6_0_1_0)"
arch=('x86_64')
@@ -19,10 +19,10 @@ conflicts=(
'msp430-elf-newlib'
)
url="http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html"
-source=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_0_1_0/exports/msp430-gcc-7.3.1.24_linux64.tar.bz2")
+source=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_1_0_0/exports/msp430-gcc-7.3.2.154_linux64.7z")
license=('GPL')
options=(!strip staticlibs)
-sha256sums=('13a362cb459ae510d1b41c074d72298be45a5b7fd53ae189c38fcfdb19bcd8ac')
+sha256sums=('a85007bd64ce4d1c4d4b52c60851cfd4bf3bc23783a0a5d5c2b8ef923ce766d8')
package() {
mkdir -p $pkgdir/usr/share/man
@@ -35,4 +35,7 @@ package() {
cp -a share/man/man1 $pkgdir/usr/share/man/
cp -a share/man/man5 $pkgdir/usr/share/man/
cp -a *.* $pkgdir/usr/share/msp430-gcc/
+ # fixup permissions
+ find $pkgdir/ -perm 0700 -exec chmod 755 "{}" \;
+ find $pkgdir/ -perm 0600 -exec chmod 644 "{}" \;
}