summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2016-01-27 18:25:24 -0500
committervonPalitroque2016-01-27 18:25:24 -0500
commitc0ecf007b3b9fc71e822730a845dd7036dd389bb (patch)
treeb2b516038dc74fcd7d6648bcb17703fe375631c4
parentb5dbba10dbdca069e640f77ed88d54dcd8ab60c0 (diff)
downloadaur-c0ecf007b3b9fc71e822730a845dd7036dd389bb.tar.gz
Removed patch for line numbers.
Removed patch for line numbers, this is now handled in binutils. See [1] for details. [1] https://sourceware.org/ml/binutils/2016-01/msg00304.html
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index faed876cf5f7..b8a424162888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Dec 9 19:21:24 UTC 2015
+# Wed Jan 27 23:25:00 UTC 2016
pkgbase = msp430-elf-gdb
pkgdesc = The GNU Debugger for the msp430-elf target.
pkgver = 7.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/gdb/download/
arch = x86_64
arch = x86
groups = devel
license = GPL
depends = python2
- source = http://ftp.gnu.org/gnu/gdb/gdb-7.10.1.tar.xz
- source = fix-dwarf2read.patch
- sha256sums = 25c72f3d41c7c8554d61cacbeacd5f40993276d2ccdec43279ac546e3993d6d5
- sha256sums = 94dbe29525a65b0427548551f2a8c17fd1bfb58dcfeac0a57e14b7b1ab2cccb5
pkgname = msp430-elf-gdb
diff --git a/PKGBUILD b/PKGBUILD
index d846d08dd4bf..3f37941e284a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,21 @@
_target=msp430-elf
pkgname="${_target}-gdb"
pkgver=7.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Debugger for the ${_target} target."
arch=('x86_64' 'x86')
url="https://www.gnu.org/software/gdb/download/"
license=('GPL')
groups=('devel')
depends=("python2")
-source=("http://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz"
- fix-dwarf2read.patch)
-sha256sums=('25c72f3d41c7c8554d61cacbeacd5f40993276d2ccdec43279ac546e3993d6d5'
- '94dbe29525a65b0427548551f2a8c17fd1bfb58dcfeac0a57e14b7b1ab2cccb5')
+sources=("http://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz")
+
prepare() {
cd "$srcdir/gdb-$pkgver"
[[ -d gdb-build ]] && rm -rf gdb-build
mkdir gdb-build
- # temporary fix for
- # https://sourceware.org/bugzilla/show_bug.cgi?id=19033
- patch -p1 < ../fix-dwarf2read.patch
# fix libiberty
# sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure