summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2020-03-17 11:11:27 -0400
committervonPalitroque2020-03-17 11:11:27 -0400
commitfdd568c8382aecda2e4aa0351d612690b671b25e (patch)
tree100620f726ae71e664884984577165c853fb225f
parent2747b2bc79693c7fc2ee2260aa3e4d93369d4256 (diff)
downloadaur-fdd568c8382aecda2e4aa0351d612690b671b25e.tar.gz
Enabled TUI and Guile.
Enabled TUI mode. Allow Guile to be used as a language to extend GDB. Made dependencies more inline with the PKGBUILDs in the official repos.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3191ee74062..4451907a0b50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = msp430-elf-gdb
pkgdesc = The GNU Debugger for the msp430-elf target.
pkgver = 9.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/gdb/download/
arch = x86_64
arch = x86
@@ -9,6 +9,11 @@ pkgbase = msp430-elf-gdb
license = GPL
depends = python
depends = readline
+ depends = ncurses
+ depends = gdb-common
+ depends = guile
+ depends = expat
+ depends = xz
source = http://ftp.gnu.org/gnu/gdb/gdb-9.1.tar.xz
sha256sums = 699e0ec832fdd2f21c8266171ea5bf44024bd05164fdf064e4d10cc4cf0d1737
diff --git a/PKGBUILD b/PKGBUILD
index 6af61f952ed3..fd6a6acd6d9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_target=msp430-elf
pkgname="${_target}-gdb"
pkgver=9.1
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Debugger for the ${_target} target."
arch=('x86_64' 'x86')
url="https://www.gnu.org/software/gdb/download/"
license=('GPL')
groups=('devel')
-depends=("python" "readline")
+depends=("python" "readline" "ncurses" "gdb-common" "guile" "expat" "xz")
source=("http://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz")
sha256sums=('699e0ec832fdd2f21c8266171ea5bf44024bd05164fdf064e4d10cc4cf0d1737')
@@ -35,16 +35,17 @@ build() {
# build gdb
../configure \
--prefix=/usr \
- --without-guile \
--target=${_target} \
--host=${CHOST} \
--build=${CHOST} \
--with-sysroot=/usr/${_target} \
--disable-nls \
--with-python=/usr/bin/python \
+ --enable-multilib \
--with-system-readline \
--disable-werror \
- --disable-tui
+ --enable-tui \
+ --with-guile
make
}
@@ -54,11 +55,8 @@ package() {
cd "$srcdir/gdb-$pkgver/gdb-build"
make DESTDIR="$pkgdir" install
- # fix conflicts
- # rm -f ${pkgdir}/usr/lib/libiberty.a
+ # handle conflicts
rm -r ${pkgdir}/usr/share/info
- # rm -r ${pkgdir}/usr/{info,man}
-
rm -r ${pkgdir}/usr/share/man
rm -r ${pkgdir}/usr/share/gdb/
rm -r ${pkgdir}/usr/include/gdb