summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2015-09-29 17:09:43 -0400
committervonPalitroque2015-09-29 17:09:43 -0400
commit038836e95307eb5e840df4d8afe76aaeeccba92f (patch)
tree068c315c96030de3c736a4e1bb8d5fd37af51bef
parent58bf741d39a96fe51377657de759fd5d86a0faf8 (diff)
downloadaur-038836e95307eb5e840df4d8afe76aaeeccba92f.tar.gz
Newlib compiles with debug symbols.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5873b379fb43..66327c35aadd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = msp430-elf-newlib
pkgdesc = C library for bare metal systems msp430-elf target.
pkgver = 2.2.0.20150824
- pkgrel = 1
+ pkgrel = 2
url = https://sourceware.org/newlib/
arch = any
groups = devel
license = GPL
depends = msp430-elf-gcc-stage1
depends = msp430-elf-binutils
+ options = !makeflags
options = !strip
options = staticlibs
source = ftp://sourceware.org/pub/newlib/newlib-2.2.0.20150824.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 360478ef562d..1b40807b0484 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_target=msp430-elf
pkgname=${_target}-newlib
pkgver=2.2.0.20150824
-pkgrel=1
+pkgrel=2
pkgdesc="C library for bare metal systems ${_target} target."
arch=(any)
url="https://sourceware.org/newlib/"
license=('GPL')
groups=(devel)
depends=("${_target}-gcc-stage1" "${_target}-binutils")
-options=('!strip' 'staticlibs')
+options=('!makeflags' '!strip' 'staticlibs')
source=("ftp://sourceware.org/pub/newlib/newlib-${pkgver}.tar.gz")
sha256sums=('05c4a82974f30487ded7965465acdd3f726ea487e1398f118e52c516b4aad093')
@@ -23,7 +23,7 @@ prepare() {
build() {
cd "${srcdir}/newlib-${pkgver}/newlib-build"
- export CFLAGS_FOR_TARGET="-Os -ffunction-sections -fdata-sections"
+ export CFLAGS_FOR_TARGET="-Os -g -ffunction-sections -fdata-sections"
../configure \
--prefix=/usr \
--target=${_target} \