summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2018-04-09 12:50:09 -0400
committervonPalitroque2018-04-09 12:50:09 -0400
commit0935e538fef6aea69b016dd7e0b6b47e674edd31 (patch)
treecadd7ce173651053eb254f912e0553c148d74082
parent6df75553da32d2ddf20542046861e547885899f3 (diff)
downloadaur-0935e538fef6aea69b016dd7e0b6b47e674edd31.tar.gz
Updated to latest upstream version.
Updated to latest upstream version.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--fix_call_exit_procs.patch13
3 files changed, 7 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5877b24b0395..eaee2de4a624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 4 01:57:12 UTC 2018
+# Mon Apr 9 16:49:49 UTC 2018
pkgbase = msp430-elf-newlib
pkgdesc = C library for bare metal systems for the msp430-elf target.
- pkgver = 3.0.0
+ pkgver = 3.0.0.20180226
pkgrel = 1
url = https://sourceware.org/newlib/
arch = any
@@ -14,10 +14,8 @@ pkgbase = msp430-elf-newlib
options = !strip
options = staticlibs
options = !libtool
- source = ftp://sourceware.org/pub/newlib/newlib-3.0.0.tar.gz
- source = fix_call_exit_procs.patch
- sha256sums = c8566335ee74e5fcaeb8595b4ebd0400c4b043d6acb3263ecb1314f8f5501332
- sha256sums = d1b2a7d12de24841b3210de09bf52c7c8babdabbdfbc2caa818b2ae805959a7c
+ source = ftp://sourceware.org/pub/newlib/newlib-3.0.0.20180226.tar.gz
+ sha256sums = d0b40c874c3047eccbf06fe916d3fc746bd94e8a4cd14c54381b2f72f68c5665
pkgname = msp430-elf-newlib
diff --git a/PKGBUILD b/PKGBUILD
index 44b562771329..38b7d42bc347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target=msp430-elf
pkgname=${_target}-newlib
-pkgver=3.0.0
+pkgver=3.0.0.20180226
pkgrel=1
pkgdesc="C library for bare metal systems for the ${_target} target."
arch=(any)
@@ -11,18 +11,12 @@ license=('BSD')
groups=(devel)
depends=("${_target}-gcc-stage1" "${_target}-binutils")
options=('!makeflags' '!strip' 'staticlibs' '!libtool')
-source=("ftp://sourceware.org/pub/newlib/newlib-${pkgver}.tar.gz"
- fix_call_exit_procs.patch)
-sha256sums=('c8566335ee74e5fcaeb8595b4ebd0400c4b043d6acb3263ecb1314f8f5501332'
- 'd1b2a7d12de24841b3210de09bf52c7c8babdabbdfbc2caa818b2ae805959a7c')
+source=("ftp://sourceware.org/pub/newlib/newlib-${pkgver}.tar.gz")
+sha256sums=('d0b40c874c3047eccbf06fe916d3fc746bd94e8a4cd14c54381b2f72f68c5665')
prepare() {
cd "${srcdir}/newlib-${pkgver}"
- # apply commit b7e0f286a2ecab3b687ec9b3f95f5a88b9f85310 so we can actually
- # build newlib with --enable-lite-exit
- patch -p1 < ../fix_call_exit_procs.patch
-
[[ -d newlib-build ]] && rm -rf newlib-build
mkdir newlib-build
}
diff --git a/fix_call_exit_procs.patch b/fix_call_exit_procs.patch
deleted file mode 100644
index 41cc6d8cb369..000000000000
--- a/fix_call_exit_procs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/newlib/libc/stdlib/exit.c b/newlib/libc/stdlib/exit.c
-index 95108ade6..7e5a5518b 100644
---- a/newlib/libc/stdlib/exit.c
-+++ b/newlib/libc/stdlib/exit.c
-@@ -54,7 +54,7 @@ exit (int code)
- {
- #ifdef _LITE_EXIT
- /* Refer to comments in __atexit.c for more details of lite exit. */
-- void __call_exitprocs (int, void *)) __attribute__((weak);
-+ void __call_exitprocs (int, void *) __attribute__((weak));
- if (__call_exitprocs)
- #endif
- __call_exitprocs (code, NULL);