summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvonPalitroque2018-02-03 20:57:23 -0500
committervonPalitroque2018-02-03 20:57:23 -0500
commit6df75553da32d2ddf20542046861e547885899f3 (patch)
tree8518108510971d2bfb9692a49f4f78f1e5a2dc50
parentb6799164e6f27ba6d23544d3cf262b8d8bad43ff (diff)
downloadaur-6df75553da32d2ddf20542046861e547885899f3.tar.gz
Updated to latest upstream release.
Updated to latest upstream release. A patch must be applied manually to fix a syntax error that would prevent newlib from being built.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--fix_call_exit_procs.patch13
3 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56c157f0006b..5877b24b0395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Sep 25 14:54:06 UTC 2017
+# Sun Feb 4 01:57:12 UTC 2018
pkgbase = msp430-elf-newlib
pkgdesc = C library for bare metal systems for the msp430-elf target.
- pkgver = 2.5.0.20170922
+ pkgver = 3.0.0
pkgrel = 1
url = https://sourceware.org/newlib/
arch = any
@@ -14,8 +14,10 @@ pkgbase = msp430-elf-newlib
options = !strip
options = staticlibs
options = !libtool
- source = ftp://sourceware.org/pub/newlib/newlib-2.5.0.20170922.tar.gz
- sha256sums = 16ccacbb9155b89a8333da057bfd2952d334795a38dfffcef6a4d83ae12e7275
+ source = ftp://sourceware.org/pub/newlib/newlib-3.0.0.tar.gz
+ source = fix_call_exit_procs.patch
+ sha256sums = c8566335ee74e5fcaeb8595b4ebd0400c4b043d6acb3263ecb1314f8f5501332
+ sha256sums = d1b2a7d12de24841b3210de09bf52c7c8babdabbdfbc2caa818b2ae805959a7c
pkgname = msp430-elf-newlib
diff --git a/PKGBUILD b/PKGBUILD
index 9ad898a45777..44b562771329 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target=msp430-elf
pkgname=${_target}-newlib
-pkgver=2.5.0.20170922
+pkgver=3.0.0
pkgrel=1
pkgdesc="C library for bare metal systems for the ${_target} target."
arch=(any)
@@ -11,11 +11,18 @@ license=('BSD')
groups=(devel)
depends=("${_target}-gcc-stage1" "${_target}-binutils")
options=('!makeflags' '!strip' 'staticlibs' '!libtool')
-source=("ftp://sourceware.org/pub/newlib/newlib-${pkgver}.tar.gz")
-sha256sums=('16ccacbb9155b89a8333da057bfd2952d334795a38dfffcef6a4d83ae12e7275')
+source=("ftp://sourceware.org/pub/newlib/newlib-${pkgver}.tar.gz"
+ fix_call_exit_procs.patch)
+sha256sums=('c8566335ee74e5fcaeb8595b4ebd0400c4b043d6acb3263ecb1314f8f5501332'
+ 'd1b2a7d12de24841b3210de09bf52c7c8babdabbdfbc2caa818b2ae805959a7c')
prepare() {
cd "${srcdir}/newlib-${pkgver}"
+
+ # apply commit b7e0f286a2ecab3b687ec9b3f95f5a88b9f85310 so we can actually
+ # build newlib with --enable-lite-exit
+ patch -p1 < ../fix_call_exit_procs.patch
+
[[ -d newlib-build ]] && rm -rf newlib-build
mkdir newlib-build
}
diff --git a/fix_call_exit_procs.patch b/fix_call_exit_procs.patch
new file mode 100644
index 000000000000..41cc6d8cb369
--- /dev/null
+++ b/fix_call_exit_procs.patch
@@ -0,0 +1,13 @@
+diff --git a/newlib/libc/stdlib/exit.c b/newlib/libc/stdlib/exit.c
+index 95108ade6..7e5a5518b 100644
+--- a/newlib/libc/stdlib/exit.c
++++ b/newlib/libc/stdlib/exit.c
+@@ -54,7 +54,7 @@ exit (int code)
+ {
+ #ifdef _LITE_EXIT
+ /* Refer to comments in __atexit.c for more details of lite exit. */
+- void __call_exitprocs (int, void *)) __attribute__((weak);
++ void __call_exitprocs (int, void *) __attribute__((weak));
+ if (__call_exitprocs)
+ #endif
+ __call_exitprocs (code, NULL);