summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Bero2017-04-18 11:00:39 -0500
committerChristopher Bero2017-04-18 11:00:39 -0500
commit54f7b5fd5b0bb2500f046b4777a836f4e40cab68 (patch)
tree579775f31cd524433f10acfa47914766f3242215
parentcbded28b8bc7e0f4bd544810df8c125fa25fda38 (diff)
downloadaur-54f7b5fd5b0bb2500f046b4777a836f4e40cab68.tar.gz
Workaround for missing download link, mspds version 3.09.002.015
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49710210e59a..437b9084c58a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jan 10 18:56:15 UTC 2017
+# Tue Apr 18 15:59:57 UTC 2017
pkgbase = mspds
pkgdesc = MSP430 Debug Stack. Contains a dynamic link library as well as embedded firmware that runs on the MSP-FET430UIF or the eZ430 emulators.
- pkgver = 3.09.001.002
+ pkgver = 3.09.002.015
pkgrel = 1
url = http://www.ti.com/tool/mspds
arch = i686
@@ -15,10 +15,10 @@ pkgbase = mspds
depends = hidapi
depends = boost
optdepends = mspdebug
- noextract = slac460s.zip
- source = http://www.ti.com/lit/sw/slac460s/slac460s.zip
+ noextract = msp430.dll_developer_package_rev_3_09_002_015.zip
+ source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPDS/latest/exports/msp430.dll_developer_package_rev_3_09_002_015.zip
source = hidapi.patch
- sha256sums = db9e82f177f86ef15d8f0a120f2f2a8e5132a34d592c0d9536df52c874106a9e
+ sha256sums = 709eef7be35c69bc4ce204cf8dd367b1495bd50fc00f37d5bdd60442800e60ef
sha256sums = aa2bdb86118a84423f3df752f48d90d2ebcb1e1bbc5293bdfd7fb1c62f765a34
pkgname = mspds
diff --git a/PKGBUILD b/PKGBUILD
index 4852d3e7ac24..ae87aa0154cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# PKGBUILD copied from https://github.com/greigdp/msp430-mspds
# Contributor: Alexei Colin <ac@alexeicolin.com>
pkgname=mspds
-pkgver=3.09.001.002
+pkgver=3.09.002.015
pkgrel=1
pkgdesc="MSP430 Debug Stack. Contains a dynamic link library as well as embedded firmware that runs on the MSP-FET430UIF or the eZ430 emulators."
arch=('i686' 'x86_64')
@@ -14,27 +14,27 @@ group=('msp430')
depends=('hidapi' 'boost')
makedepends=('unzip' 'dos2unix')
optdepends=('mspdebug')
-_release='slac460s'
-_releasefile="${_release}.zip"
+#_release='slac460s'
+_releasefile="msp430.dll_developer_package_rev_3_09_002_015.zip"
noextract=("${_releasefile}")
-source=("http://www.ti.com/lit/sw/${_release}/${_releasefile}"
+source=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPDS/latest/exports/msp430.dll_developer_package_rev_3_09_002_015.zip"
'hidapi.patch')
-sha256sums=('db9e82f177f86ef15d8f0a120f2f2a8e5132a34d592c0d9536df52c874106a9e'
+sha256sums=('709eef7be35c69bc4ce204cf8dd367b1495bd50fc00f37d5bdd60442800e60ef'
'aa2bdb86118a84423f3df752f48d90d2ebcb1e1bbc5293bdfd7fb1c62f765a34')
prepare() {
unzip ${_releasefile}
find ./ -type f -exec dos2unix -q '{}' \;
# This hidapi patch allows us to build mspds from the hidapi Archlinux package rather than the v0.7 source.
- patch -p1 -d . < ../hidapi.patch
+ #patch -p1 -d . < ../hidapi.patch
}
build() {
cd "$srcdir"
- make
+ #make
}
package() {
- install -Dm644 "$srcdir/libmsp430.so" "$pkgdir/usr/lib/libmsp430.so"
+ install -Dm644 "$srcdir/MSP430_DLL_Developer_Package_Rev_3_9_2_15/libmsp430.so" "$pkgdir/usr/lib/libmsp430.so"
}