summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2022-05-03 17:30:32 +0200
committerFlorian Maunier2022-05-03 17:30:32 +0200
commit22bd66903a8332e4250e528e8d370b175f65a844 (patch)
tree8fcdd1090007ef70aae183b2de7aae36bd555846
parent274f19da678b598aa6d6802c7281c7751795af86 (diff)
downloadaur-22bd66903a8332e4250e528e8d370b175f65a844.tar.gz
Upgrade to MsQuic v2.0 branch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b82b5ad716e0..b9cb71c23a36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = msquic-release-git
pkgdesc = Microsoft implementation of the IETF QUIC protocol (release, git)
- pkgver = 1.1.8.r0.g794436f54
- pkgrel = 3
+ pkgver = 2.0.3
+ pkgrel = 1
url = https://github.com/microsoft/msquic
arch = x86_64
arch = armv7h
@@ -15,9 +15,7 @@ pkgbase = msquic-release-git
provides = libmsquic.so
conflicts = msquic
conflicts = libmsquic.so
- source = msquic-release-git::git+https://github.com/microsoft/msquic.git#branch=release/1.1
- source = cmake_args.patch
+ source = msquic-release-git::git+https://github.com/microsoft/msquic.git#branch=release/2.0
sha512sums = SKIP
- sha512sums = f0eb23f885b9577f93101f9e68c6863dc896086068d3ed29e7b6924a1286ab8aa478feec42cf0fa3cfee2e5e2fb42e5be3f15451ff0954c4db2059de6ebe7c27
pkgname = msquic-release-git
diff --git a/PKGBUILD b/PKGBUILD
index 73e4f9dc9f1a..1ef32d2872b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
pkgname=msquic-release-git
-pkgver=1.1.8.r0.g794436f54
-pkgrel=3
+pkgver=2.0.3
+pkgrel=1
pkgdesc="Microsoft implementation of the IETF QUIC protocol (release, git)"
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/microsoft/msquic"
@@ -10,10 +10,8 @@ depends=('glibc')
makedepends=('cmake>=3.16' 'dotnet-sdk>=3.1' 'git')
provides=('msquic' 'libmsquic.so')
conflicts=('msquic' 'libmsquic.so')
-source=("$pkgname::git+https://github.com/microsoft/msquic.git#branch=release/1.1"
- 'cmake_args.patch')
-sha512sums=('SKIP'
- 'f0eb23f885b9577f93101f9e68c6863dc896086068d3ed29e7b6924a1286ab8aa478feec42cf0fa3cfee2e5e2fb42e5be3f15451ff0954c4db2059de6ebe7c27')
+source=("$pkgname::git+https://github.com/microsoft/msquic.git#branch=release/2.0")
+sha512sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -23,7 +21,6 @@ pkgver() {
prepare() {
cd "$pkgname"
git submodule update --init --recursive --depth=1
- patch -p1 -i "$srcdir/cmake_args.patch"
}
build() {
@@ -39,6 +36,10 @@ build() {
make -C "$pkgname/build" all
}
+check() {
+ make -C "$pkgname/build" test
+}
+
package() {
make -C "$pkgname/build" DESTDIR="$pkgdir/" install
install -D -m644 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"