summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormsrd0.dev2024-04-08 12:58:17 +0000
committermsrd0.dev2024-04-08 12:58:17 +0000
commit539a85300be1f30074b03f3ae75a652cdd7d4f1a (patch)
treebfb80f906c41fd014e8b9ee510ea25bb5f6a760d
parente81a9b63894a78b0c6c4631d385bd7b8c2cabb83 (diff)
downloadaur-539a85300be1f30074b03f3ae75a652cdd7d4f1a.tar.gz
auto-update mstickereditor 0.3.3
-rw-r--r--.SRCINFO2
-rw-r--r--.index.json2
-rw-r--r--PKGBUILD11
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caacfe08becc..3bc12dc8c222 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = mstickereditor
arch = aarch64
arch = i686
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = cargo
makedepends = clang
makedepends = lld
diff --git a/.index.json b/.index.json
index a6b47246d688..ae489aa55723 100644
--- a/.index.json
+++ b/.index.json
@@ -1,5 +1,5 @@
{
- ".i": 1,
+ ".i": 2,
"crate": "mstickereditor",
"version": "0.3.3"
} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 74ee374ef777..4e521f271104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,19 @@ pkgver=0.3.3
pkgrel=1
pkgdesc='import sticker packs from telegram, to be used at the Maunium sticker picker ...'
url='https://crates.io/crates/mstickereditor'
-license=('Apache')
+license=('Apache-2.0')
depends=('gcc-libs' 'ffmpeg' 'libwebp' 'rlottie')
makedepends=('cargo' 'clang' 'lld')
-source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/mstickereditor/0.3.3/download")
+source=("$_crate-0.3.3.tar.gz::https://crates.io/api/v1/crates/mstickereditor/0.3.3/download")
sha512sums=('6b3e73fc6ae0f6aeaff6e156365b22602e32d78bcaf35c5cc89f73c4349f3f60cd7a7559f0d8a6823ea740d09426019c5d95119f0c8e9fa5bc965952b9444f62')
# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
arch=('aarch64' 'i686' 'x86_64')
prepare() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.3.3"
export RUSTUP_TOOLCHAIN=stable
@@ -28,10 +28,11 @@ prepare() {
}
build() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.3.3"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
+ CFLAGS+=" -ffat-lto-objects"
cargo build \
@@ -43,7 +44,7 @@ build() {
}
package() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.3.3"
install -Dm755 "target/release/mstickereditor" -t "$pkgdir/usr/bin"
install -Dm644 bashcompletion "$pkgdir/usr/share/bash-completion/completions/$pkgname"
install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$pkgname/"