summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEspen Fossen2019-03-28 11:25:33 +0100
committerEspen Fossen2019-03-28 11:25:33 +0100
commitae6f576f617ef7cbecbb270486c2e75b7fb765ad (patch)
tree4a6748cc337135096c2957e2869d61c4497bf839
parent1fae557e8ba6e9274106068f196e9e80d2d073b1 (diff)
downloadaur-ae6f576f617ef7cbecbb270486c2e75b7fb765ad.tar.gz
Removed deprecated config parameters. Fixed ownership on node_modules dir.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--config.json7
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91ae9dbe3abf..a64a7e123708 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,7 @@ pkgbase = mstream
source = config.json
md5sums = edc1f3de9e2833de93ffef1123bb9bae
md5sums = 6640e102dd29a6da5c4c075e4c4042d7
- md5sums = 0bf80ec584f8b028628f4c684cdaf283
+ md5sums = 4de57ee6dedd2ab9ce7b08321a16610f
pkgname = mstream
diff --git a/PKGBUILD b/PKGBUILD
index f87ee0a2031c..c145359e01c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,8 @@ package() {
install -d -g 49 -o 49 "${pkgdir}/var/lib/${pkgname}/album-art"
install -Dm644 mstream.service "$pkgdir"/usr/lib/systemd/system/mstream.service
install -Dm644 -g 49 -o 49 config.json "${pkgdir}/var/lib/${pkgname}/config.json"
+ chown -R 49:49 "${pkgdir}/usr/lib/node_modules/${pkgname}"
}
md5sums=('edc1f3de9e2833de93ffef1123bb9bae'
'6640e102dd29a6da5c4c075e4c4042d7'
- '0bf80ec584f8b028628f4c684cdaf283')
+ '4de57ee6dedd2ab9ce7b08321a16610f')
diff --git a/config.json b/config.json
index 684f1a836158..0e909b9ffcba 100644
--- a/config.json
+++ b/config.json
@@ -1,9 +1,10 @@
{
"port": 3030,
- "database_plugin":{
- "dbPath":"/var/lib/mstream/mstream.db"
+ "noUpload": "true",
+ "storage":{
+ "albumDirectory":"/var/lib/mstream/album-art"
+ "dbDirectory":"/var/lib/mstream/"
},
- "albumArtDir": "/var/lib/mstream/album-art",
"folders": {
"media": "/var/lib/mstream/media"
}