summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFaye2020-05-10 02:30:41 -0500
committerFaye2020-05-10 02:30:41 -0500
commit26665508562abba617020d023e5fac68db466731 (patch)
treed0d3fa9772e68eabcc42044c5b757e0d4680fd39
downloadaur-26665508562abba617020d023e5fac68db466731.tar.gz
Initial Commit!
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fbf0001055d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = msync
+ pkgdesc = A low bandwidth store and forward Mastodon / Pleroma API command line client
+ pkgver = 0.9.8
+ pkgrel = 1
+ url = http://github.com/Kansattica/msync
+ arch = x86_64
+ license = GPL
+ depends = curl
+ depends = libcurl3-gnutls
+ provides = msync
+ conflicts = msync-git
+ source = https://github.com/Kansattica/msync/releases/download/v0.9.8/msync-v0.9.8-install-linux-x64-gcc
+ md5sums = 7a86f6f2b31c6f82ec38771434764505
+
+pkgname = msync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa926d50cb21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Faye Jackson <justalittleepsilon@gmail.com>
+pkgname=msync
+pkgver=0.9.8
+pkgrel=1
+_tagver="v$pkgver"
+pkgdesc="A low bandwidth store and forward Mastodon / Pleroma API command line client"
+arch=(x86_64)
+url=http://github.com/Kansattica/msync
+license=('GPL')
+depends=(curl libcurl3-gnutls)
+provides=(msync)
+conflicts=(msync-git)
+source=("https://github.com/Kansattica/msync/releases/download/${_tagver}/msync-${_tagver}-install-linux-x64-gcc")
+md5sums=('7a86f6f2b31c6f82ec38771434764505')
+
+package() {
+ cd $srcdir
+ curl "https://raw.githubusercontent.com/Kansattica/msync/master/LICENSE" > LICENSE
+ install -D -m755 "msync-${_tagver}-install-linux-x64-gcc" "${pkgdir}/usr/bin/msync"
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/msync/LICENSE"
+}