summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLobo Torres2023-11-28 14:41:40 -0300
committerLobo Torres2023-11-28 14:41:40 -0300
commit3d61d1fc7f34493a2581c909f11fce50b0daac13 (patch)
tree11339a61f3c649484e399eebb7d8102071a5a52f
parent34cc913c70d21b03bbe0cf8686602c2a5369c635 (diff)
downloadaur-3d61d1fc7f34493a2581c909f11fce50b0daac13.tar.gz
update to latest version and compile instead of downloading prebuilt binary
-rw-r--r--PKGBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e51b9a25065..134a16835dc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Faye Jackson <justalittleepsilon@gmail.com>
+# Maintainer: Lobo Torres <lobo@praderi.es>
+
pkgname=msync
-pkgver=0.9.9.3
+pkgver=0.9.9.8
pkgrel=1
-_tagver="v$pkgver"
pkgdesc="A low bandwidth store and forward Mastodon / Pleroma API command line client"
-arch=(x86_64)
-url=http://github.com/Kansattica/msync
-license=('GPL')
-depends=(curl libcurl3-gnutls)
-provides=(msync)
-conflicts=(msync-git)
-source=("https://github.com/Kansattica/msync/releases/download/${_tagver}/msync-${_tagver}-install-linux-x64-gcc")
-md5sums=('3f7c54bcc9e6d52f8fe30acc073fc94b')
+arch=(any)
+url="https://github.com/Kansattica/msync"
+license=("GPL-3.0-only")
+depends=(curl)
+makedepends=(gcc cmake pandoc)
+changelog=
+source=("https://github.com/Kansattica/msync/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=("12519be285fd2b0e5a29d610b7971f90b4a9a449e46a78ec830bc0c2df9c4fad")
+
+build() {
+ cd "$srcdir/msync-${pkgver}"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DMSYNC_BUILD_TESTS=OFF -DMSYNC_USER_CONFIG=ON -DMSYNC_FILE_LOG=OFF
+ cmake --build . --parallel
+ cd "$srcdir/msync-${pkgver}"
+ bash ./scripts/make_man_page.sh ./build/msync
+}
package() {
- cd $srcdir
- curl "https://raw.githubusercontent.com/Kansattica/msync/master/LICENSE" > LICENSE
- install -D -m755 "msync-${_tagver}-install-linux-x64-gcc" "${pkgdir}/usr/bin/msync"
+ cd "$srcdir/msync-${pkgver}"
+ install -Dm0755 build/msync "$pkgdir/usr/bin/msync"
+ install -Dm0644 msync.1.gz "$pkgdir/usr/share/man/man1/msync.1.gz"
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/msync/LICENSE"
}