summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-05-27 16:07:51 -0400
committerChris Severance2016-05-27 16:07:51 -0400
commite006edd023ed2b53e739bcbc977958ccfba5cb20 (patch)
treedc47d276248112235c2865ed5279184eea1e6354
parent9d9d8ef65ba79ee6a267eacb0e33054eec638b8e (diff)
downloadaur-e006edd023ed2b53e739bcbc977958ccfba5cb20.tar.gz
Remove make dependency on pcre2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 005080621ef5..6e097cdf3d86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri May 27 20:07:07 UTC 2016
pkgbase = mt-st-git
pkgdesc = Utilities for managing magnetic tape storage devices
pkgver = 1.1.r6.gece9c03
diff --git a/PKGBUILD b/PKGBUILD
index 44a09090e774..8ff1731bd369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,12 +11,12 @@ pkgdesc='Utilities for managing magnetic tape storage devices'
arch=('i686' 'x86_64')
url="https://github.com/Distrotech/${_pkgname}"
license=('GPLv2')
-makedepends=('git')
depends=('tar')
-source=("${_pkgname}::${url//https/git}.git")
-sha256sums=('SKIP')
+makedepends=('git')
provides=("${_pkgname}=${pkgver%.r*}")
conflicts=("${_pkgname}")
+source=("${_pkgname}::${url//https/git}.git")
+sha256sums=('SKIP')
pkgver() {
set -u
@@ -47,7 +47,9 @@ package() {
! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
+ if command -v 'pcre2grep' >/dev/null 2>&1; then
+ ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
+ fi
}
set +u