summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDale Whinham2021-05-23 22:56:42 +0100
committerDale Whinham2021-05-23 22:56:42 +0100
commit57925ffb367d090c88ddb38e971e5684eb64c366 (patch)
tree730c650133e57098fcd7dfa8deced7b1df70f102
downloadaur-57925ffb367d090c88ddb38e971e5684eb64c366.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29dc02ca26dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mt32-pi-control
+ pkgdesc = A control program for the mt32-pi MIDI synthesizer
+ pkgver = 1.0.0a
+ pkgrel = 1
+ url = https://github.com/gmcn42/mt32-pi-control
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ depends = alsa-lib
+ source = https://github.com/gmcn42/mt32-pi-control/archive/v1.0.0a.tar.gz
+ sha256sums = ff86af3b29d814452831b066cde2e47271d658a447e213e56bb4e992f0434a1e
+
+pkgname = mt32-pi-control
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be4e5cdd192f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Dale Whinham <daleyo at gmail dot com>
+pkgname=mt32-pi-control
+pkgver=1.0.0a
+pkgrel=1
+pkgdesc="A control program for the mt32-pi MIDI synthesizer"
+arch=("i686" "x86_64" "armv7h" "aarch64")
+url="https://github.com/gmcn42/mt32-pi-control"
+license=("BSD")
+depends=("alsa-lib")
+source=("https://github.com/gmcn42/mt32-pi-control/archive/v$pkgver.tar.gz")
+sha256sums=("ff86af3b29d814452831b066cde2e47271d658a447e213e56bb4e992f0434a1e")
+
+build() {
+ cd "$srcdir"/"$pkgname"-"$pkgver"
+ mkdir -p linux_bin
+ make -C linux_src -j dist
+}
+
+package() {
+ cd "$srcdir"/"$pkgname"-"$pkgver"
+ install -Dm755 linux_bin/mt32-pi-ctl "$pkgdir"/usr/bin/mt32-pi-ctl
+ install -Dm644 linux_bin/mt32pi.bmp "$pkgdir"/usr/share/"$pkgname"/mt32pi.bmp
+ install -m644 README.md "$pkgdir"/usr/share/"$pkgname"/README.md
+
+ # License is BSD 2-clause and needs to be installed
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}