summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Scarpetta2017-09-17 10:00:51 +0200
committerMarco Scarpetta2017-09-17 10:00:51 +0200
commit26a729d080c8c1120ff09a6aa6bcc0dc8ac43c1d (patch)
treee7fe1844443439d17523b97fb8eee6a16e996f61
downloadaur-26a729d080c8c1120ff09a6aa6bcc0dc8ac43c1d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
-rw-r--r--mt7601.install16
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5069cb3b8436
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 17 07:59:46 UTC 2017
+pkgbase = mt7601usta-odroid-c2
+ pkgdesc = MediaTek MT7601U chip driver for kernel version before 3.19
+ pkgver = r58.4ea9747
+ pkgrel = 1
+ url = https://github.com/art567/mt7601usta
+ install = mt7601.install
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ makedepends = linux-headers>=3.0
+ depends = linux>=3.0
+ depends = linux<3.19
+ source = git+https://github.com/art567/mt7601usta.git#commit=4ea974775ed9ea1bb09396b08a39c4cb807009ca
+ md5sums = SKIP
+
+pkgname = mt7601usta-odroid-c2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d57f6e0c6afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Marco Scarpetta <marcoscarpetta02 at gmail dot com>
+
+_gitcommit=4ea974775ed9ea1bb09396b08a39c4cb807009ca
+
+pkgname=mt7601usta-odroid-c2
+pkgver=r58.4ea9747
+pkgrel=1
+pkgdesc="MediaTek MT7601U chip driver for kernel version before 3.19"
+arch=('aarch64')
+url="https://github.com/art567/mt7601usta"
+license=('GPL')
+install=mt7601.install
+depends=('linux>=3.0' 'linux<3.19')
+makedepends=('git' 'linux-headers>=3.0')
+source=("git+${url}.git#commit=${_gitcommit}")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/mt7601usta"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/mt7601usta/src"
+ make
+}
+
+package() {
+ cd "$srcdir/mt7601usta/src"
+
+ install -Dm644 RT2870STA.dat "$pkgdir/etc/Wireless/RT2870STA/RT2870STA.dat"
+ install -Dm644 os/linux/mt7601Usta.ko "$pkgdir/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/mt7601Usta.ko"
+}
diff --git a/mt7601.install b/mt7601.install
new file mode 100644
index 000000000000..cb7abfa76771
--- /dev/null
+++ b/mt7601.install
@@ -0,0 +1,16 @@
+post_install() {
+ depmod -a $(uname -r)
+
+ echo '!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!'
+ echo '!!! To make your device work you must add "coherent_pool=4M" !!!'
+ echo '!!! to the line "setenv bootargs" of your /boot/boot.ini file !!!'
+ echo '!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}