summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkreon2017-01-31 21:47:57 +0300
committerkreon2017-01-31 21:48:09 +0300
commit01cac611dc0d5bfa0aec24ac186be5f17a574238 (patch)
tree8917cc48af72fcc9298b5cd961ec7c5e821f5239
parent5c1232db93f347ea49564895aa0e0ea46c6cf2c3 (diff)
downloadaur-mt7610u_wifi_sta.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--0002-add-tplink-archer-t1u.patch11
-rw-r--r--PKGBUILD7
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73fac48321cb..56f5df062015 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 7 19:51:03 UTC 2016
+# Tue Jan 31 18:47:59 UTC 2017
pkgbase = mt7610u_wifi_sta
pkgdesc = Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more
pkgver = 4606187
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916
install = depmod.install
arch = any
@@ -13,8 +13,10 @@ pkgbase = mt7610u_wifi_sta
depends = linux
source = mt7610u_wifi_sta::git+https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916.git
source = 0001-fix-compile-against-kernel-4.6.patch
+ source = 0002-add-tplink-archer-t1u.patch
md5sums = SKIP
md5sums = aef239125f6420706d7bf5252455d4af
+ md5sums = 45476e7b0ccad4812069ea4f943b29c0
pkgname = mt7610u_wifi_sta
diff --git a/0002-add-tplink-archer-t1u.patch b/0002-add-tplink-archer-t1u.patch
new file mode 100644
index 000000000000..ddc8bad096c3
--- /dev/null
+++ b/0002-add-tplink-archer-t1u.patch
@@ -0,0 +1,11 @@
+diff -Nura mt7610u_wifi_sta/common/rtusb_dev_id.c mt7610u_wifi_sta_b/common/rtusb_dev_id.c
+--- mt7610u_wifi_sta/common/rtusb_dev_id.c 2017-01-31 21:46:20.345297040 +0300
++++ mt7610u_wifi_sta_b/common/rtusb_dev_id.c 2017-01-31 21:45:49.958480956 +0300
+@@ -42,6 +42,7 @@
+ {USB_DEVICE(0x7392,0xA711)}, /* Edimax 7711ULC/7711MAC */
+ {USB_DEVICE(0x7392,0xB711)}, /* Elecom WDC-433SU2M */
+ {USB_DEVICE(0x148F,0x761A)}, /* TP-LINK Archer T2UH */
++ {USB_DEVICE(0x2357,0x0105)}, /* TP-LINK Archer T1U */
+ {USB_DEVICE(0x148F,0x760A)}, /* TP-LINK */
+ {USB_DEVICE(0x0B05,0x17D1)}, /* ASUS USB-AC51 */
+ {USB_DEVICE(0x0B05,0x17DB)}, /* ASUS USB-AC50 */
diff --git a/PKGBUILD b/PKGBUILD
index a350f836a02f..3c1d999c5612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mt7610u_wifi_sta
pkgver=4606187
-pkgrel=2
+pkgrel=3
# To get an overview of witch WiFi dongle has this chipset refer to https://wikidevi.com/wiki/MediaTek_MT7610U
pkgdesc="Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more"
arch=('any')
@@ -12,12 +12,13 @@ url="https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916"
depends=('linux')
makedepends=('git' 'linux-headers')
install="depmod.install"
-source=("mt7610u_wifi_sta"::"git+https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916.git" "0001-fix-compile-against-kernel-4.6.patch")
-md5sums=('SKIP' 'aef239125f6420706d7bf5252455d4af')
+source=("mt7610u_wifi_sta"::"git+https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916.git" "0001-fix-compile-against-kernel-4.6.patch" "0002-add-tplink-archer-t1u.patch")
+md5sums=('SKIP' 'aef239125f6420706d7bf5252455d4af' '45476e7b0ccad4812069ea4f943b29c0')
build() {
cd "${srcdir}/${pkgname}"
patch -p1 < "${srcdir}/0001-fix-compile-against-kernel-4.6.patch"
+ patch -p1 < "${srcdir}/0002-add-tplink-archer-t1u.patch"
make -C "${srcdir}/${pkgname}"
}