summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBanned Patriot2021-07-14 11:52:12 -0500
committerBanned Patriot2021-07-14 11:52:12 -0500
commit1d653540b6bee257cc99df633d0aad2640181b2b (patch)
tree1743dd7fefa55ace4bc15360e2aaa68cc0573d98
downloadaur-1d653540b6bee257cc99df633d0aad2640181b2b.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--depmod.install15
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ef5c68c9643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mt7610u_wifi_sta-alt
+ pkgdesc = Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/BannedPatriot/mt7610u_wifi_sta.git
+ install = depmod.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = linux-headers
+ depends = linux
+ conflicts = mt7610u_wifi_sta
+ replaces = mt7610u_wifi_sta
+ source = mt7610u_wifi_sta-alt::git+https://github.com/BannedPatriot/mt7610u_wifi_sta.git
+ md5sums = SKIP
+
+pkgname = mt7610u_wifi_sta-alt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccb5698a1f95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Banned Patriot <realbannedpatriot@protonmail.com>
+# Based on the PKGBUILD created by Yannick Inizan <inizan[dot]yannick[at]gmail[dot]com>, derived from Ivan Agarkov <ivan[dot]agarkov[at]gmail[dot]com>
+
+pkgname=mt7610u_wifi_sta-alt
+pkgver=1
+pkgrel=1
+# To get an overview of witch WiFi dongle has this chipset refer to https://wikidevi.com/wiki/MediaTek_MT7610U
+pkgdesc="Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more"
+arch=('any')
+license=('GPL2')
+url="https://github.com/BannedPatriot/mt7610u_wifi_sta.git"
+conflicts=('mt7610u_wifi_sta')
+replaces=('mt7610u_wifi_sta')
+depends=('linux')
+makedepends=('git' 'linux-headers')
+install="depmod.install"
+source=("mt7610u_wifi_sta-alt"::"git+https://github.com/BannedPatriot/mt7610u_wifi_sta.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make -C "${srcdir}/${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p "${pkgdir}/etc/Wireless/RT2870STA"
+ mkdir -p "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux"
+ install -m 644 -t "${pkgdir}/etc/Wireless/RT2870STA" RT2870STA.dat
+ install -m 644 -t "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux" os/linux/*.ko
+}
diff --git a/depmod.install b/depmod.install
new file mode 100644
index 000000000000..fb8d863ea3cf
--- /dev/null
+++ b/depmod.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -e "\e[34;1m==>\e[39;1m Running depmod... \e[0m"
+ depmod
+ echo -e "\e[34;1m==>\e[39;1m NOTE: Module name is mt7650u_sta \e[0m"
+}
+
+post_upgrade() {
+ echo -e "\e[34;1m==>\e[39;1m Running depmod... \e[0m"
+ depmod
+}
+
+post_remove() {
+ echo -e "\e[34;1m==>\e[39;1m Running depmod... \e[0m"
+ depmod
+}