summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2019-09-30 10:21:38 -0400
committerJean-Francois Chevrette2019-09-30 10:21:38 -0400
commitdab94c326fc3dee1c7334a5fcaa603c6a3fbf21c (patch)
tree9f4fbe2352ea9dc15f17de0bb342e2c0e178fff7
downloadaur-dab94c326fc3dee1c7334a5fcaa603c6a3fbf21c.tar.gz
initial import v3.0.0_rc33
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2616d816ea38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mtail-bin
+ pkgdesc = extract whitebox monitoring data from application logs for collection in a timeseries database
+ pkgver = v3.0.0_rc33
+ pkgrel = 2
+ url = https://github.com/google/mtail
+ arch = x86_64
+ license = Apache
+ conflicts = mtail
+ source = https://github.com/google/mtail/releases/download/v3.0.0-rc33/mtail_v3.0.0-rc33_linux_amd64
+ source = https://raw.githubusercontent.com/google/mtail/master/LICENSE
+ sha256sums = 5119d74d6d5519fcd4c32c25bcc144e32ff42dfc6fde32bc3af752423459fa9b
+ sha256sums = cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30
+
+pkgname = mtail-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29ed282cfd04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jean-Francois Chevrette <jfchevrette@gmail.com>
+
+_pkgname='mtail'
+pkgname="${_pkgname}-bin"
+_pkgver=v3.0.0-rc33
+pkgver="${_pkgver//-/_}"
+pkgrel=2
+pkgdesc='extract whitebox monitoring data from application logs for collection in a timeseries database'
+arch=('x86_64')
+url='https://github.com/google/mtail'
+license=('Apache')
+conflicts=("${_pkgname}")
+source=("https://github.com/google/mtail/releases/download/${_pkgver}/${_pkgname}_${_pkgver}_linux_amd64"
+ "https://raw.githubusercontent.com/google/mtail/master/LICENSE")
+sha256sums=('5119d74d6d5519fcd4c32c25bcc144e32ff42dfc6fde32bc3af752423459fa9b'
+ 'cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm755 "mtail_${_pkgver}_linux_amd64" "${pkgdir}/usr/bin/mtail"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}