summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorax342020-04-12 04:13:13 +0300
committerax342020-04-12 04:13:13 +0300
commit197d1fd7c5420724813c9fdb36cabe2640b40bd1 (patch)
treefdcd2849b4cca5cffb6a2a9466c2632bfee94186
parent14269179c1622c07eed08bced1c4626ad4e7091a (diff)
downloadaur-197d1fd7c5420724813c9fdb36cabe2640b40bd1.tar.gz
Use tha git, Luke
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05bd23bb590e..9e9efd9ef33c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mtpaint-wjaguar
pkgdesc = Simple paint program for creating icons and pixel based artwork (Dmitry Groshevs fork)
pkgver = 3.49.26
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wjaguar/mtPaint
arch = x86_64
license = GPL3
@@ -14,8 +14,8 @@ pkgbase = mtpaint-wjaguar
optdepends = gifsicle: for exporting GIF files from mtPaint
provides = mtpaint
conflicts = mtpaint
- source = mtpaint-3.49.26.zip::https://github.com/wjaguar/mtPaint/archive/66a1716c124ae888f7997ca229ef2b0b507dcc71.zip
- sha256sums = c05ac2963736b12b900c3d26e4d1bf71b4561741d1687641e72b8dbe65b86488
+ source = git+https://github.com/wjaguar/mtPaint.git#commit=66a1716c124ae888f7997ca229ef2b0b507dcc71
+ sha256sums = SKIP
pkgname = mtpaint-wjaguar
diff --git a/PKGBUILD b/PKGBUILD
index aa04e1b0fd01..d43477e27b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,7 @@
pkgname=mtpaint-wjaguar
pkgver=3.49.26
-pkgrel=1
-_commit="66a1716c124ae888f7997ca229ef2b0b507dcc71"
+pkgrel=2
pkgdesc='Simple paint program for creating icons and pixel based artwork (Dmitry Groshev''s fork)'
arch=('x86_64')
url='https://github.com/wjaguar/mtPaint'
@@ -16,25 +15,23 @@ depends=('gtk3' 'giflib' 'openjpeg' 'lcms2' 'libwebp' 'libtiff')
optdepends=('gifsicle: for exporting GIF files from mtPaint')
provides=('mtpaint')
conflicts=('mtpaint')
-source=("mtpaint-$pkgver.zip::https://github.com/wjaguar/mtPaint/archive/$_commit.zip")
-sha256sums=('c05ac2963736b12b900c3d26e4d1bf71b4561741d1687641e72b8dbe65b86488')
+source=("git+https://github.com/wjaguar/mtPaint.git#commit=66a1716c124ae888f7997ca229ef2b0b507dcc71")
+sha256sums=('SKIP')
prepare() {
- cd "mtPaint-$_commit"
+ cd "mtPaint"
# Recommended by Mark Tyler himself
sed -i 's:$LIBS $LDFLAGS:$LDFLAGS $LIBS:' configure
}
build() {
- cd "mtPaint-$_commit"
+ cd "mtPaint"
./configure --prefix=/usr --mandir=/usr/share/man man intl GIF jpeg tiff cflags lcms2 jp2 webp gtk3
make
}
package() {
- make -C "mtPaint-$_commit" DESTDIR="$pkgdir" install
+ make -C "mtPaint" DESTDIR="$pkgdir" install
}
-
-# vim:ts=2 sw=2 et: